Failed to set pipeline to PAUSED

After install deepstream3 for tesla by the manual, tried to run the sample as below, but got error. The gpu is one tesla k80. TensorRT5, Nvidia driver410.48, Cuda10.0, GStreamer 1.14.1 are installed on Ubuntu 18.04 LTS. Tried to remove the cache but no use. Tried all config files, all not working.

deepstream-app -c /home/eliyart/Deepstream/samples/configs/deepstream-app/config_dewarper.txt
** ERROR: main:564: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(1616): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

Any suggestion, thanks.

Hi, Alexum
you are not supporsed to use config_dewarper.txt directly, you can get the detailed info about plugin
dewarper within ds package, DeepStream_3.0_Plugin_Manual.pdf 2.9 GST-NVDEWARPER, for deepstream-app
running, you can try deepstream-app -c /ds package/samples/configs/deepstream-app/source30_720p_dec_infer-resnet_tiled_display_int8.txt or source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

Hi Amycao,

Thank you very much for your reply. I tried the command below, and it gives some errors.

deepstream-app -c /ds source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt
** ERROR: <parse_config_file:287>: parse_config_file failed
** ERROR: main:535: Failed to parse config file ‘/ds’
Quitting
App run failed

Then I tried the command without ‘/ds’. A black window will appear, but finally it still give some error. Any suggestion, thanks.

deepstream-app -c source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarMake/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarColor/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_VehicleTypes/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Primary_Detector/resnet10.caffemodel_b4_int8.engine crypto flags(0)

Runtime commands:
h: Print this help
q: Quit

p: Pause
r: Resume

NOTE: To expand a source in the 2D tiled display and view object details, left-click on the source.
To go back to the tiled display, right-click anywhere on the window.

**PERF: FPS 0 (Avg) FPS 1 (Avg) FPS 2 (Avg) FPS 3 (Avg)
**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
** INFO: <bus_callback:98>: Pipeline ready

cuGraphicsGLRegisterBuffer failed with error(999) gst_eglglessink_cuda_init texture = 1
** INFO: <bus_callback:84>: Pipeline running

**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
**PERF: 68.48 (68.48) 68.48 (68.48) 68.48 (68.48) 68.48 (68.48)
**PERF: 0.00 (68.48) 0.00 (68.48) 0.00 (68.48) 0.00 (68.48)
**PERF: 0.00 (68.48) 0.00 (68.48) 0.00 (68.48) 0.00 (68.48)
**PERF: 0.00 (68.48) 0.00 (68.48) 0.00 (68.48) 0.00 (68.48)
**PERF: 0.00 (68.48) 0.00 (68.48) 0.00 (68.48) 0.00 (68.48)
ERROR from secondary_gie_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:secondary_gie_bin/GstQueue:secondary_gie_bin_queue:
streaming stopped, reason not-negotiated (-4)
Quitting
ERROR from sink_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstQueue:sink_bin_queue:
streaming stopped, reason not-negotiated (-4)
App run failed

if you want to output to display, you should run on desktop with monitor connected physically, or you
can login to desktop by nomachine or some other tools, and also nvidia graphic card needed for display.

Hi Amycao,

I am using vncview to remotely connect to the ubuntu desktop. It can play the normal video. When run the config file, it show up a new black windows, and after sometimes, the window terminate. From the log, there seems a error in the end, not sure if it is related. Assume that the black window should show something, but due to some error it does not show it. Any suggestion, thanks.

Can you paste output of ldd /path to ds package/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libnvdsgst_eglglessink.so

Here is the ldd results, is there anything not correct, thanks.

$ ldd ds libnvdsgst_eglglessink.so
ds:
ldd: ./ds: No such file or directory
libnvdsgst_eglglessink.so:
linux-vdso.so.1 (0x00007ffda87fe000)
libcudart.so.10.0 => /usr/local/cuda-10.0/lib64/libcudart.so.10.0 (0x00007f87689c4000)
libcuda.so.1 => /usr/lib/x86_64-linux-gnu/libcuda.so.1 (0x00007f87678ce000)
libGLESv2.so.2 => /usr/lib/x86_64-linux-gnu/libGLESv2.so.2 (0x00007f87676bc000)
libEGL.so.1 => /usr/lib/x86_64-linux-gnu/libEGL.so.1 (0x00007f87674a8000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f8767170000)
libgstreamer-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0 (0x00007f8766e35000)
libgstbase-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-1.0.so.0 (0x00007f8766bc0000)
libgstvideo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-1.0.so.0 (0x00007f8766928000)
libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f8766612000)
libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f87663be000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f8766020000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8765c2f000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f8765a2b000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f876580c000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f8765604000)
libnvidia-fatbinaryloader.so.410.48 => /usr/lib/x86_64-linux-gnu/libnvidia-fatbinaryloader.so.410.48 (0x00007f87653b7000)
libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f8765101000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f8764ed9000)
libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f8764cd5000)
liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f8764a59000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f87647e7000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f87645df000)
/lib64/ld-linux-x86-64.so.2 (0x00007f8768e5c000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f87643db000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f87641d5000)
libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f8763fc0000)

when you install nvidia graphic driver, Do you install opengl as prompted? if not please reinstall driver and try again.

Many thanks, tried to upgrade nvidia driver to 410.93 by downloaded run file. In the installation process, a pre script failed, but seems no effect on installation. And there is no prompt for opengl. I tried other ways to install opengl, all failed. Any suggestion, thanks.

How many graphic cards in your system? and how about the cards series respectively? what card are you
using for display? nvidia or integrated? default config source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt is for sink type 2 EglSink,
that needs nvidia graphic card for display, which will require you install nvidia driver with
opengl installed and nvidia x config set up, for run file install, not sure if promoted opengl install,
but deb file install have, but they should be similar, and you can check the result also can by sink to
file, by disable sink0, enable sink1 in config.

The system only have 1 graphic card Tesla k80. It is on google cloud. VNCserver and VNC client is used for remote display. When disable sink0, enable sink1 in config, it gave the error as below.

deepstream-app -c souce4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt
** ERROR: <parse_config_file:287>: parse_config_file failed
** ERROR: main:535: Failed to parse config file ‘souce4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt’
Quitting
App run failed

Tried to run a simple opengl script in link http://www.codebind.com/linux-tutorials/install-opengl-ubuntu-linux/ It gave error as below.

./firstOpenGlApp
freeglut (./firstOpenGlApp): OpenGL GLX extension not supported by display ‘:1’

Any suggestion, thanks.

you can login to desktop by vnc, right? if that, nvidia opengl be not selected when you install nvidia
driver, if you want display, nvidia opengl should not be selected, but if you want to run deepstream
with sink type 2 Eglsink, nvidia opengl required, here i mean nvidia opengl is not standard opengl, like
mesa opengl, as suggest you can use type 1 Fakesink or 3 File, Can you paste the config after modified
which happened error you pasted as above

Yes, I can login by vnc. The command to start vnc server on google cloud is as below.

vncserver -geometry 1024x640
New ‘X’ desktop is instance-3:1
Starting applications specified in /home/eliyart/.vnc/xstartup
Log file is /home/eliyart/.vnc/instance-3:1.log

The content of the config file is as below. By the way, where can get .deb file version nvidia driver, thanks.

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[tiled-display]
enable=1
rows=2
columns=2
width=1280
height=720
gpu-id=0

0 - cuda pinned/host memory

1 - cuda device memory

2 - cuda unified memory

cuda-memory-type=1

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
uri=file://…/…/streams/sample_720p.mp4
num-sources=4
gpu-id=0

0 - cuda pinned/host memory

1 - cuda device memory

2 - cuda unified memory

cuda-memory-type=1

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=1
source-id=0
gpu-id=0
cuda-memory-type=1

[sink1]
enable=0
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265 3=mpeg4

only SW mpeg4 is supported right now.

codec=3
sync=0
bitrate=2000000
output-file=out.mp4
source-id=0

[sink2]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming
type=4
#1=mp4 2=mkv
container=2
#1=h264 2=h265 3=mpeg4

only mpeg4 is supported right now.

codec=1
sync=0
bitrate=4000

set below properties in case of RTSPStreaming

rtsp-port=8554
udp-port=5400

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Arial
show-clock=0
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
clock-color=1;0;0;0
cuda-memory-type=1

[streammux]
gpu-id=0
##Boolean property to inform muxer that sources are live
live-source=0
batch-size=4
##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=40000

Set muxer output width and height

width=1280
height=720
##Enable to maintain aspect ratio wrt source, and allow black borders, works
##along with width, height properties
enable-padding=0
cuda-memory-type=1

config-file property is mandatory for any gie section.

Other properties are optional and if set will override the properties set in

the infer config file.

[primary-gie]
enable=1
gpu-id=0
model-engine-file=…/…/models/Primary_Detector/resnet10.caffemodel_b4_int8.engine
labelfile-path=…/…/models/Primary_Detector/labels.txt
batch-size=4
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
interval=0
gie-unique-id=1
cuda-memory-type=1
config-file=config_infer_primary.txt

[tracker]
enable=1
tracker-width=640
tracker-height=368
gpu-id=0

[secondary-gie0]
enable=1
model-engine-file=…/…/models/Secondary_VehicleTypes/resnet18.caffemodel_b16_int8.engine
labelfile-path=…/…/models/Secondary_VehicleTypes/labels.txt
gpu-id=0
batch-size=16
gie-unique-id=4
operate-on-gie-id=1
operate-on-class-ids=0;
config-file=config_infer_secondary_vehicletypes.txt

[secondary-gie1]
enable=1
model-engine-file=…/…/models/Secondary_CarColor/resnet18.caffemodel_b16_int8.engine
labelfile-path=…/…/models/Secondary_CarColor/labels.txt
batch-size=16
gpu-id=0
gie-unique-id=5
operate-on-gie-id=1
operate-on-class-ids=0;
config-file=config_infer_secondary_carcolor.txt

[secondary-gie2]
enable=1
model-engine-file=…/…/models/Secondary_CarMake/resnet18.caffemodel_b16_int8.engine
labelfile-path=…/…/models/Secondary_CarMake/labels.txt
batch-size=16
gpu-id=0
gie-unique-id=6
operate-on-gie-id=1
operate-on-class-ids=0;
config-file=config_infer_secondary_carmake.txt

[tests]
file-loop=0

Any suggestion, thanks.

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=1
source-id=0
gpu-id=0
cuda-memory-type=1

above from your paste, this use type 2 EglSink, if you want to use FakeSink, change
type=2 to type=1

if want to sink to file, disable sink0 and enable sink1

[sink0]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=1
source-id=0
gpu-id=0
cuda-memory-type=1

[sink1]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265 3=mpeg4

only SW mpeg4 is supported right now.

codec=3
sync=0
bitrate=2000000
output-file=out.mp4
source-id=0

Hi AmyCao,

When set to FakeSink with type=1, it can run successfully as below.

deepstream-app -c source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarMake/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarColor/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_VehicleTypes/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Primary_Detector/resnet10.caffemodel_b4_int8.engine crypto flags(0)

Runtime commands:
h: Print this help
q: Quit

p: Pause
r: Resume

NOTE: To expand a source in the 2D tiled display and view object details, left-click on the source.
To go back to the tiled display, right-click anywhere on the window.

**PERF: FPS 0 (Avg) FPS 1 (Avg) FPS 2 (Avg) FPS 3 (Avg)
**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
** INFO: <bus_callback:98>: Pipeline ready

** INFO: <bus_callback:84>: Pipeline running

**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
**PERF: 43.12 (43.12) 43.12 (43.12) 43.12 (43.12) 43.12 (43.12)
**PERF: 30.00 (36.26) 30.00 (36.26) 30.00 (36.26) 30.00 (36.26)
**PERF: 30.00 (34.11) 30.00 (34.11) 30.00 (34.11) 30.00 (34.11)
**PERF: 30.00 (33.06) 30.00 (33.06) 30.00 (33.06) 30.00 (33.06)
**PERF: 30.00 (32.44) 30.00 (32.44) 30.00 (32.44) 30.00 (32.44)
**PERF: 30.00 (32.03) 30.00 (32.03) 30.00 (32.03) 30.00 (32.03)
**PERF: 30.00 (31.73) 30.00 (31.73) 30.00 (31.73) 30.00 (31.73)
**PERF: 30.00 (31.51) 30.00 (31.51) 30.00 (31.51) 30.00 (31.51)
**PERF: 30.00 (31.34) 30.00 (31.34) 30.00 (31.34) 30.00 (31.34)
** INFO: <bus_callback:121>: Received EOS. Exiting …

Quitting
App run successful

And when using sink1 instead of sink0, it can also run successfully.

deepstream-app -c source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarMake/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_CarColor/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Secondary_VehicleTypes/resnet18.caffemodel_b16_int8.engine crypto flags(0)
Using TRT model serialized engine /home/eliyart/Deepstream/samples/configs/deepstream-app/…/…/models/Primary_Detector/resnet10.caffemodel_b4_int8.engine crypto flags(0)

Runtime commands:
h: Print this help
q: Quit

p: Pause
r: Resume

NOTE: To expand a source in the 2D tiled display and view object details, left-click on the source.
To go back to the tiled display, right-click anywhere on the window.

** INFO: <bus_callback:98>: Pipeline ready

** INFO: <bus_callback:84>: Pipeline running

**PERF: FPS 0 (Avg) FPS 1 (Avg) FPS 2 (Avg) FPS 3 (Avg)
**PERF: 43.03 (43.03) 42.61 (42.61) 42.61 (42.61) 43.03 (43.03)
**PERF: 45.62 (44.62) 45.62 (44.45) 45.62 (44.45) 45.62 (44.62)
**PERF: 45.38 (44.91) 45.38 (44.80) 45.38 (44.80) 45.38 (44.91)
**PERF: 45.58 (45.09) 45.58 (45.02) 45.58 (45.02) 45.58 (45.09)
**PERF: 45.17 (45.11) 45.17 (45.05) 45.17 (45.05) 45.17 (45.11)
**PERF: 45.04 (45.10) 45.04 (45.05) 45.04 (45.05) 45.04 (45.10)
** INFO: <bus_callback:121>: Received EOS. Exiting …

Quitting
App run successful

Really appreciate for your help. It seem only type 3 not work. Type 3 eglsink seems based on use EGLImage+OpenGLes, based on X11. It may due to OpenGLes or config of X11. Anyway, thanks again.