Failed to set USB3 to compliance mode


We are testing USB3 with Nano EVB board.
But we cannot set bit8:5 0f 0x70090420 to 0xa.

Here is the test result.

Thank you for any advice,

  1. Not quite sure why you are doing compliance test over devkit. NV already did that for you…What you are doing seems meaningless.

  2. I already told you in another thread over NX forum. Every compliance test over an external hub requires the hub vendor for help. The document provided from us is for no external hub case.

Hi WanynWWW,

Thank you for your support.

This issue is solved on our customer’s carrier board by following compliance test doc.

The reason why we did test compliance test over devkit is for our customer asked.
Our customer had frustrated on USB compliance test and had gotten failed on both EVB board and their carrier board.
We did the test to know if the test command worked or not on devkit.
Unfortunately, it did not work even we ran Realtek hub driver which you provided on another thread over Nano forum. ( see the picture I uploaded.)
Although, It was dramatic to set USB compliance mode successfully on their carrier board in the end. But the value of 0x03610440 was always 0x2a0, no matter if 0x10340 was written to 0x03610440 or not. No matter, the test pattern sent out or not. It’s hard to know if test pattern sent or not from 0x03610440.

If you have another way to know if USB compliance test mode is setting ok or not, could you share with us.

Anyway. still thank you for your support.

Hi, are you testing on nano or Xavier NX? If nano, please refer to nano Guide.

Hi ,

We tested both Nano and NX.
And followed Nano guide to test Nano and NX guide to test NX.
And all got the similar result.
Which never got Bits[8:5] should be set to 0xa?

Thank you,

Hi, there is USB hub on nano and NX devkit.

Please refer to this topic: Usb 3.0 compliance test with hub

Thank you for your support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.