Failed to start mst service (Windows cannot verify the digital signature for this file)

Hello All,

I have two HPE-Mellanox adapters on 2 Servers:

1- HPE Ethernet 25Gb 2-port 640SFP28 Adapter

2- HPE Ethernet 25Gb 2-port 640FLR-SFP28 Adapter

I updated the latest drivers (DriverVersion: 1.60.16216.0) and firmware successfully on one Node.

On the second node, I was able to update the driver using pnputil.exe command, however, I am not able to run the mst status.

I installed the latest WinMFT tool (WinMFT_x64_4_6_0_48.exe) on each node.

Please find the error below:

-E- MST devices:

No MST devices found

-E- Failed to start mst service (577): Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.

I am running Windows Server 2016 and Windows Defender is running. I excluded the following path in Windows Defender but still the same issue:

ExclusionPath : {C:\Program Files\Mellanox}

ExclusionProcess : {mst.exe, mst_ib_add.exe}

Please help.

Thank you!


Thank you Aviap,

I disabled secure boot from BIOS to solve this issue.



Hi Charbel,

I have the same problem right now.

Thanks to mellanox support: Try to disable secure boot feature in bios.

Regards from Germany,


Thank you Sebastian,

I cannot disable “secure boot” feature in my server, it won’t boot.

The question is, how I was able to run it successfully on the first node with “Secure Boot” enabled?

Both nodes are identical.

Looking for Mellanox support feedback!



Could be an issue related to the WinOF-2 driver v1.60.16216.0 you are using

remove the driver above, reboot the server and install WinOF-2 v1.60.16227 ( )

this one is “windows 2016” dedicated, and reboot the server

  • if issue still persist - then run # sc delete mst64

  • issue still persist, run # set MTCR_DEBUG_LEVEL=5 then # mst status -

you will be receiving the a message indicating that mst is not feasible in the presence of “security-boot” enabled

  • Disable "security boot " in the BIOS as Sebastian suggested to you earlier

  • Run # mst status - you should be able to see the nics

hope this helps