Failed to start Nvidia Persistence daemon

Was using pycharm and torch no problem, Installed Cuda working OK. powered down over the weekend and when I powered back up I got this error

Failed to start Nvidia Persistence daemon

Any help would be appreciated


Could you use ctrl+alt +F1~6 to switch to console?

If you can, use the command you see on the picture to check what happened to that daemon.

Thank you very much for answering. I will be away from my system until Friday. I will try it when I get back


Thomas Eckenrode

I tried the ctrl+alt +F1~6 but it did not work

Then use the serial console to access your board.

got the login prompt using the serial access port but nothing happens when I type user bane. No letters show up

What keyboard are you using here? You know that you have to use the keyboard on your host side, don’t you?

yes I am using that

Are you able to reflash the whole board with sdkmanager again?

yes. Do you think its because I moved ubuntu and everything else to the 500GB card I have and boot from that. I did that because I was low on memory after I installed tensorflow, pytorch, and pycharm

Hmm… actually there are two issues here

  1. The first problem in your first comment. That may have some connection with how you moved ubuntu to external drive. How did you configure it?

  2. The second problem is the uart gets only RX but no TX. Since this is jetson AGX Xavier, there is no chance that you didn’t wire the cable correctly…

BTW, this is a AGX devkit but not some custom boards, right? I think it would be better if you can tell detail of your board from the beginning of the thread. For example, you should tell that you put the file system into the 500GB card from the beginning, not until now.

sorry about that. its the AGX dev kit. From jetsonhacks Jetson Xavier NX - Run from SSD - YouTube

Flash your board without ssd first and validate the uart serial console can work or not first.

If it can work fine, follow below method to boot from nvme.

will do thank you. will let you tomorrow. Appreciate your help

Sorry for the dumb question but how do you get to the uboot prompt

AGX does not have uboot. Not sure why you ask this question.

All the bootloader log is from the serial console too.

Because I was following these instructions
To set up an NVMe drive manually for booting steps 7,8,9 worked great. But it was 10 that mentioned uboot

7.Connect the Jetson device to a host computer and put it into recovery mode, then enter the following commands to generate the rootfs without flashing the device:

$ cd Linux_for_Tegra/

$ sudo BOOTDEV=nvme0n1p1 ./ --no-flash nvme0n1p1

$ sudo mkdir tmp_system

$ sudo mount bootloader/system.img.raw ./tmp_system

$ sudo rsync -axHAWX --numeric-ids --info=progress2 --exclude=/proc ./tmp_system/ /mnt

Where nvme0n1p1 is the device name that the Jetson device will assign to APP.

8.Unmount the NVMe drive and disconnect it from the host computer:

$ sudo umount /mnt

$ sudo umount ./tmp_system

9.Plug the NVMe drive into the target device and power on.

10.Set booting from NVMe drive in U-Boot environment:

•To test directly, enter run bootcmd_nvme0 at the U Boot prompt.

•To set NVMe to boot first with a plain boot command, change the U‑Boot variable boot_targets to “nvme0 mmc1 mmc0 usb0 pxe dhcp”, then enter the U‑Boot command run boot.

•To make the change permanent, run saveenv in U-Boot after changing boot_targets but before booting

No need to care about the steps with uboot. That is for jetson Nano and TX2. For xavier NX/AGX, cboot by default will boot from NVMe.

BTW, is your TX on the uart serial console able to work now?

When I put the NVMe into the board and power on I get this at the terminal

bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell