Failed when dump ram using "tegrarcm_v2 --oem dumpram offset len"

I tried dump ram using “tegrarcm_v2 --oem dumpram offset len”, but failed, could you give me some suggestions?
Below is the screenshot in the shell:

root@test# ./tegrarcm_v2 --oem checkdumpramrequest 0x10000 0x100
Applet version 01.00.0000

However “tegrcm_v2 --oem dump bct xxx.bct” is ok, I can get the bct from the target.

Dear merlinwu,

Can I know why are you trying to dump ram contents?
Are there any issue for using DPX2? Thanks.

I just found this function in tegrarcm_v2 and want to have a try.

And I have several questions about DPX2

  1. When I tried flash the Tegra Parker, I found that most of the binaries are prebuilt, how can I generate my own binaries such as “mb1-bootloader”, “mb2-bootloader”?


Dear merlinwu,

Yes, we provide the bootloaderfile for stable boot up.
Probably it is not easy to generate customer own binaries such as “mb1-bootloader”.
Can I know why do you need to generate your own binaries for mb1-bootloader? Thanks.

Because of curiosity, it looks interesting. Could you provide some suggestions?