Failing to Install Cuda Extenionsons on Google Colab (Wheel Error)

I am trying to run the code of stable-dreamfusion in a Google Colab notebook, which as I see its working for others, but I am encountering installation errors for several packages (raymarching, shencoder, freqencoder, and gridencoder). The installation fails during the execution of install.sh, with the following error for each package:

Installing collected packages: raymarching
error: subprocess-exited-with-error

× Running setup.py install for raymarching did not run successfully.
│ exit code: 1
╰─> See above for output.

note: This error originates from a subprocess, and is likely not a problem with pip.
Running setup.py install for raymarching ... error
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> raymarching

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure."

Expected behavior
Successfully install cuda extensions

**Additional **
1.Go to https://colab.research.google.com/drive/1MXT3yfOFvO0ooKEfiUUvTKwUkrrlCHpF?usp=sharing
2. Run install dependencies