Fails to create GLX context with graphics interception plugin


LGD 2.2 worked so far on my desktop computer (Mint 18.2, GeForce GTX 970) until I updated this morning. I got a new version of the NVidia driver (384.90), that might be the issue.

Now, any application fails to create the GLX context if I preload the graphics interception plugin. Without the plugin, everything works properly. If I launch glxgears for instance, I got:

# LD_PRELOAD=~/.tgd/libs/ glxgears   
LGD: Starting GTI initialization...
LGD: GLX vendor: NVIDIA Corporation
LGD: Graphics interception initialized
Xlib:  extension "NV-GLX" missing on display ":0".
Error: glXCreateContext failed

Besides the driver update, I also got a kernel update, here is the output of uname -a:

Linux IRCW122 4.10.0-38-generic #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Any advice on this ?

The driver seems to be the problem. I forced the version to 384.90-0ubuntu0.16.04.1 and now it works.
So the newest version 384.90-0ubuntu0.16.04.2 does not work for me, although it is only supposed to be only a security update.


Glad it works for you.
I suggest using the driver downloaded from Nvidia official site but not the ones provided in Ubuntu.