failure to change hostname

Hi!

In installed pgi 8.0 successfully last year but need to change the hostname recently to allow the proper creation of mpd rings (for mpich2). I have gone into the license.dat file and changed the name from localhost.localdomain to airpolicy1 (as specified in my /etc/hosts file) and followed the instructions for restarting the license manager. However I am getting the following (usual) error:

12:31:10 (lmgrd) -----------------------------------------------
12:31:10 (lmgrd) Please Note:
12:31:10 (lmgrd)
12:31:10 (lmgrd) This log is intended for debug purposes only.
12:31:10 (lmgrd) In order to capture accurate license
12:31:10 (lmgrd) usage data into an organized repository,
12:31:10 (lmgrd) please enable report logging. Use Macrovision’s
12:31:10 (lmgrd) software license administration solution,
12:31:10 (lmgrd) FLEXnet Manager, to readily gain visibility
12:31:10 (lmgrd) into license usage data and to create
12:31:10 (lmgrd) insightful reports on critical information like
12:31:10 (lmgrd) license availability and usage. FLEXnet Manager
12:31:10 (lmgrd) can be fully automated to run these reports on
12:31:10 (lmgrd) schedule and can be used to track license
12:31:10 (lmgrd) servers and usage across a heterogeneous
12:31:10 (lmgrd) network of servers including Windows NT, Linux
12:31:10 (lmgrd) and UNIX. Contact Macrovision at
12:31:10 (lmgrd) www.macrovision.com for more details on how to
12:31:10 (lmgrd) obtain an evaluation copy of FLEXnet Manager
12:31:10 (lmgrd) for your enterprise.
12:31:10 (lmgrd)
12:31:10 (lmgrd) -----------------------------------------------
12:31:10 (lmgrd)
12:31:10 (lmgrd)
12:31:10 (lmgrd) The license server manager (lmgrd) running as root:
12:31:10 (lmgrd) This is a potential security problem
12:31:10 (lmgrd) and is not recommended.
12:31:10 (lmgrd) Failed to open the TCP port number in the license.

When I try and pgf77 -V x.f I get (not suprisingly) a series of failure to checkout error messages and a cannot connect to server error. Finally, I get a FLEXnet licensing error -15,570 System Error: 101 “Network is unreachable”

I know in one of the other posts with a similar problem there was some question regarding resetting the firewall and the port settings but I have tried this with no effect.

I’m sure this is very simple but I am out of ideas.

Any and all suggestions are greatly appreciated.

Thanks,

David

David,

Unfortunately, the license mail ends on my plate, so the answers may seem familiar.
If you know the real IP address of your machine, say 123.456.789.001, and are allowed to

rsh 123.456.789.001 ‘date’
or
ssh 123.456.789.001 ‘date’

then editing the license file and changing the hostname to
123.456.789.001 should work.If it does,
then airpolicy1 should map to 123.456.789.001 in /etc/hosts.
Your IT people should first approve such a change - we don’t
want to step on your security - but that is the essence of a solution.
Could be that they want DNS to map it to a fake IPA.

localhost should map to 127.0.0.1 in /etc/hosts,
the loopback IP address, and can work as well, if allowed.

Each time you edit the license file, restart lmgrd.

If this is an OSX machine, airpolicy1.local may be the name to use,

wrt the TCP port number, first make sure the license can find the
platform. Once that is done, try editing the PORT number to be 7496.

Unfortunately, we do not know a way to list the available ports on a system.

dave