Failure to flash OS image to Cardhu dev kit.


I am new to Cardhu dev kit and I have been scratching my head on flashing the JB image. I tried flashing on 32-bit Ubuntu first and failed. Then I found the guide document and followed exactly the description on Windows. I’ve been able to install the recovery driver and place the kit in forced recovery mode. I received the identical error message on Linux when I ran flashos.bat file.

Here is the command window output:


u>nvflash.exe --bct flash.bct --setbct --odmdata 0x40080000 --configfile flash.c
fg --create --bl bootloader.bin --go
Nvflash started
rcm version 0X30001
System Information:
chip name: unknown
chip id: 0x30 major: 1 minor: 3
chip sku: 0x81
chip uid: 0x015c7b47ea2bf208
macrovision: disabled
hdcp: enabled
sbk burned: false
dk burned: false
boot device: emmc
operating mode: 3
device config strap: 0
device config fuse: 0
sdram config strap: 1

sending file: flash.bct

  • 6128/6128 bytes sent
    flash.bct sent successfully
    odm data: 0x40080000
    downloading bootloader – load address: 0x80108000 entry point: 0x80108000
    sending file: bootloader.bin
    data send failed NvError 0x120002
    command failure: bootloader download failed (bad data)


Thanks for the bug report - we’ll look into this and get back to you.

BTW, mine is a Tegra3 developer tablet, S/N: 0413012010048. On Windows XP 32-bit, I downloaded and installed tegra-devpack-2.0-windows-2012-10-22-14091158.exe and tegra-osinstaller-cardhu-jb-1.0-windows-2012-10-20-11617556.exe.

The tablet arrived with JB and Fastboot pre-installed, I think.

Hi, yyuan

“sdram config strap: 1” could indicate some board issue of NAND. Can you contact people where you get the devkit from for reparing or supporting?

Also, some board’s USB is sensitive to cable. Remove any extension cable and shorten you USB connection.

Thanks Xuan,

I only used the shipped cable. I also tried a 3ft cable without success.

Hi yyuan,

Was your JB flashing success? Could you please let me know the steps you followed?


I am also facing same issue.
Please can some body help us here ?