Fan not spinning, gets really hot. (Auvidea J120)

We noticed yesterday that the Tx1 fan didn’t spin, and the module was really hot.

How do we figure out what’s wrong? The cables are firmly plugged in. We can power the fan externally but I’d rather not.

do you have a general diagnostics tool to do a general checkup on the device?

it also doesn’t twitch on startup

Try this:

sudo su
<give password>
echo 255 > /sys/kernel/debug/tegra_fan/target_pwm   # This should start the fan
echo 0 > /sys/kernel/debug/tegra_fan/target_pwm     # This should stop the fan (after some time)
exit

We fixed the problem.

We use a different carrier board (the Auvidea j120) I didn’t initially think it was dependent on that.

Turns out to turn the fan on, you need to initialize and set GPIO 19 to 0 @restart.

Thanks honey for helping with the debug!

How do you initialize and set the GPIO? I have a J140 board and as per the auvidea website, it is basically a J120 with some extra gigabit Ethernet ports.
Thanks!

I successfully flashed Jetpack 3.2.1 (L4T 28.2) with Auvidea J120 board today. But I noticed the fan doesn’t turn on ever since.

Also when I ls /sys/kernel/debug/tegra_*, there’s no tegra_fan at all. There’s only tegra_gpio file there. Any clue?

@Auvidea, can you help? Thanks.

jcli, take a look here

https://devtalk.nvidia.com/default/topic/1028361/jetson-tx2/auvidea-j120-imu-rev-7-carrier-board-/post/5231072/#5231072

and here:

https://devtalk.nvidia.com/default/topic/1028361/jetson-tx2/auvidea-j120-imu-rev-7-carrier-board-/post/5234110/#5234110

The info above is for TX2, for TX1 the GPIO numbers and device tree file names are different, but should be the same concept.

-albertr

albertr, thanks for the link. I wonder are you flashing your TX2 using Auvidea firmware or latest JetPack 3.3 (L4T 28.2.1 for Jetson TX2/TX2i and L4T 28.2 for Jetson TX1) from NVidia?

I flashed on J120 with later. I found the fan is always off. I tried to control the GPIO, but I got this:

nvidia@tegra-ubuntu:~$ sudo su
[sudo] password for nvidia:
root@tegra-ubuntu:/home/nvidia# echo 398 > /sys/class/gpio/export
bash: echo: write error: Invalid argument

How can I find the GPIO number for TX1 on J120? I’m a newbie, please give me some hints. Thanks.

Ok, according to this post: https://devtalk.nvidia.com/default/topic/937478/jetson-tx1/auvidea-j120-support-/post/5137055/#5137055, if a TX1 module sits on J120 carrier board, the GPIO is 19 or 219.

I tried below with both, GPIO219 works (I flashed my TX1 on J120 board with Jetpack 3.3, which includes L4T 28.2 for Jetson TX1):

nvidia@tegra-ubuntu:~$ sudo su
[sudo] password for nvidia:
root@tegra-ubuntu:/home/nvidia# echo 219 > /sys/class/gpio/export
root@tegra-ubuntu:/home/nvidia# echo “out” > /sys/class/gpio/gpio219/direction
root@tegra-ubuntu:/home/nvidia# echo 1 > /sys/class/gpio/gpio219/value # Turn off FAN
root@tegra-ubuntu:/home/nvidia# echo 0 > /sys/class/gpio/gpio219/value # Turn on FAN