Fan on GTX 960 jumps to 100% during X session (Arch Linux)

Symptoms: When I run startx, the fan slowly accelerates to max. When I exit back to console, the fan slowly decelerates back to normal.

Things that may be relevant: using no session manager or display manager. I am using Compiz + Emerald + xdesktop, Linux-ck-haswell + nvidia-ck-haswell. I’m on an I7 5820k + ASRock x99 board using EFIStub to boot.

In nvdock under Thermal Settings, it shows my GPU temp at 27-29°C and 0 rpm for Fan0 speed. nvidia-smi shows fan speed at 33%. I enabled fan speed control for nvidia-settings but changing the value has no effect. If I set fan speed in nvidia-settings, nvidia-smi reflects the change but actual fan speed does not change. I tried reverting to stock kernel and driver from official repo but problem persists. Using nouveau driver does not exibit this problem.

Reference post at Arch forums.
dmesg
journalctl
Xorg.0.log

Got the same issue with GTX 1070 on debian, tried different versions of driver (367.57, 375.26, 378.09 beta) - no changes.
Is there any solution for this issue?