FAQ: 9.0 specification conformity

Q. Are all directives and features defined in the PGI Accelerator programming model supported in the PGI 9.0 compilers?

A. Concurrent with our release 9.0, PGI is making the PGI Accelerator Model version 1.0 document available; there are a few features in the model that we have not yet implemented, the most important of which, we think, is device-resident data. User-directed loop unrolling by the compiler is also very important, and is not yet supported in PGI 9.0. Our target is to implement the full 1.0 model in our next major release in Q4 2009.