Farm task cannot be completed

Hello!
I’m running a render job via a farm queue
However, the task is not running, and judging by the errors in the log, dependencies of an older version than the one I have are requested. How to deal with this?

2023-11-09 10:47:54 [7,860ms] [Error] [omni.ext.plugin] Failed to resolve extension dependencies. Failure hints:
	Can't find extension to satisfy dependency: (name: 'omni.services.client', tag: '', version: '0.4.0', exact: 1, optional: 0)
 Available versions:
	 - [omni.services.client-0.5.1] (c:/users/ssl75/appdata/local/ov/pkg/create-2023.2.0/extscache/omni.services.client-0.5.1)
 Platform incompatible packages:
	 - [omni.services.client-0.4.0+cp37] (c:/users/ssl75/appdata/local/ov/pkg/farm-agent-104.2.0/jobs/create-render/exts-job.omni.farm.render/omni.services.client-0.4.0+cp37)
	Can't find extension to satisfy dependency: (name: 'omni.services.transport.client.base', tag: '', version: '1.2.1', exact: 1, optional: 0)
 Available versions:
	 - [omni.services.transport.client.base-1.2.3] (c:/users/ssl75/appdata/local/ov/pkg/create-2023.2.0/extscache/omni.services.transport.client.base-1.2.3)
 Platform incompatible packages:
	 - [omni.services.transport.client.base-1.2.1+cp37] (c:/users/ssl75/appdata/local/ov/pkg/farm-agent-104.2.0/jobs/create-render/exts-job.omni.farm.render/omni.services.transport.client.base-1.2.1+cp37)
	Can't find extension to satisfy dependency: (name: 'omni.services.transport.client.http_async', tag: '', version: '1.3.2', exact: 1, optional: 0)
 Available versions:
	 - [omni.services.transport.client.http_async-1.3.4] (c:/users/ssl75/appdata/local/ov/pkg/create-2023.2.0/extscache/omni.services.transport.client.http_async-1.3.4)
 Platform incompatible packages:
	 - [omni.services.transport.client.http_async-1.3.2+cp37] (c:/users/ssl75/appdata/local/ov/pkg/farm-agent-104.2.0/jobs/create-render/exts-job.omni.farm.render/omni.services.transport.client.http_async-1.3.2+cp37)

2023-11-09 10:47:54 [7,861ms] [Error] [omni.kit.app.plugin] Exiting app because of dependency solver failure...
2023-11-09 10:47:54 [7,861ms] [Info] [omni.kit.app.plugin] No run loop was found, quitting...

Can anyone help me figure out why dependencies are not resolved?

@smaga388 i am just another OV user and, unfortunately, i do not have experiences using the farm and a mod/dev would be a better resource. that said, based on the console information you posted, i am wondering if the following extensions are either missing or out of date:

  • omni.services.client-0.5.1
  • omni.services.transport.client.base-1.2.3
  • omni.services.transport.client.http_async-1.3.4

is there anyway for you to confirm those exist?

@Simplychenable Thanks for the answer, and YES, these extensions are available, but it seems to me that the farm needs older versions to work, and it does not accept new ones. This is strange, and it’s not clear what to do.

Let me see if I can get you someone who is an expert in the Farm Rendering system