Fedora 18 support?

I have the PGI version 12.1 fortran compilers. Can they work with the gcc 4.7.2 libraries that come with Fedora 18? A compilation with pgf77 fails with the message

/usr/bin/ld: cannot find /usr/lib/gcc/x86_64-redhat-linux/4.6.2/crtbegin.o: No such file or directory

I’m tempted to just link 4.6.2 to 4.7.2 Has anybody tried this successfully?

Hi John,

Support for Fedora 18 wont be available until the 13.5 release. You can see which version of the compilers support which OS at: http://www.pgroup.com/support/install.htm#linux_info

In some cases, older compilers can still be used on newer OS, but I’d need to refer you to PGI Customer Service (trs@prgroup.com) for specifics.

  • Mat