Fedora 19 (i686) nvidia akmod 331.49: still fails to boot (ZOTAC GeForce GT 520 PCI)

Ok, this has been haunting me for weeks. System used to run fine, then yum updated and it hasn’t worked since. I even reinstalled Fedora and tried installing the nvidia drivers from scratch. No go.

Here’s my thread on the Fedora forums:
http://forums.fedoraforum.org/showthread.php?t=294601

This trouble is on an old box I hang onto, it’s a Pentium III, socket 370 rig with a PCI 520 card. Yes, old system, but drivers and card both worked flawlessly before.

I read how to get a bug report log, and managed to collect it from the system using a live cd (cause I can’t, again, boot into the gui). Well, here it is.

It’s basically just:
“[ 43.954] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[ 43.956] (EE) NVIDIA: system’s kernel log for additional error messages.
[ 43.956] (EE) No devices detected.
[ 43.956] (EE)”

From my quick glance over. So for whatever reason, something changed with the newer nvidia drivers (or with akmod) and it just can not detect my card I take it.

Bug report says kernel 3.9.5, but I have the latest 3.11 kernel as well. I just can’t boot 3.11, the screen starts flashing. So I had to run nvidia-bug-report.sh with the 3.9.5 kernel. I can run it again with the 3.11 kernel, but it’s really hard to type with the screen flashing.

EDIT

Ok, removed the 3.9.5 kernel log attachment and included the 3.11 log (3.11.4-201.fc19.i686)

edit2

Here’s what “/sbin/lspci | grep VGA” shows for my display:
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)
02:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520] (rev a1)

The first one is the old onboard video.

nvidia-bug-report.log (253 KB)

Install the drivers from the http://rpmfusion.org/ repo.

The error message that you see means you haven’t built your kernel module (original NVIDIA drivers from nvidia.com are incompatible with 3.11.x onward).

All rpmfusion nvidia driver packages are compatible with 3.11

That’s what I said.

I’ve tried installing the nvidia drivers using the same way I have since Fedora 16:

http://www.if-not-true-then-false.com/2013/fedora-19-nvidia-guide/

I’ve installed drivers for Fedora for 3 years, this time they’re not simply picking up my 520, or not building the kernel for it. Something fails, I don’t know what or why.

edit

Is the bug report log showing up for download? For me it shows "[SCANNING… PLEASE WAIT] nvidia-bug-report.log "

leigh responded to me on the Fedora forum here:
http://forums.fedoraforum.org/showpost.php?p=1673710&postcount=15

“It looks like there a bug in 325.15”

And he recommended I downgrade to 304xx ( yum install akmod-nvidia-304xx xorg-x11-drv-nvidia-304xx-libs )

And 304 works fine. So nothing really more I can say, just happy I was able to report a bug and I hope it helps someone.

I have a NVIDIA G84 [GeForce 8600 GT] (rev a1) on x86_64 fedora 19 with 3.11.8 kernel and experienced the same issue as reported by Veeshush. I also had installed nvidia drivers on previous versions of fedora and OpenSUSE for 5 years on the same computer and did not encounter any problem ever.
What happens is that after installing the “akmod-nvidia xorg-x11-drv-nvidia-libs” the system failed when trying to launch the KDE login. I was not able to get the desktop working at all even with startx and had to use the VT (init 1) to uninstall the nvidia driver and reuse the nouveau driver.
The instructions at http://www.if-not-true-then-false.com/2013/fedora-19-nvidia-guide/ specify that the 304xx driver version is for GeForce 6/7 cards and so I have not tried it.
Is this issue affecting more people than Veeshush and me and if it does, is there any resolution coming up to fix it?

Bumping this and changed the title. This issue still exist with 331.20.

Going to upload the nvidia-bug-report log to my dropbox as last time I had issues uploading it on the forum:

https://dl.dropboxusercontent.com/u/51814840/nvidia-bug-report.log.gz

The only way I am able to boot into GUI is to use 304 as described a few posts above ( yum install akmod-nvidia-304xx xorg-x11-drv-nvidia-304xx-libs )

Still not working with 331.49.

Here’s the nvidia bug report:
https://dl.dropboxusercontent.com/u/51814840/331.49%20nvidia-bug-report.log.gz

I don’t really know what else to do but to keep trying every so often and keep reporting here.