Fedora 20 problems

I have two issues with OpenGL since I upgraded to Fedora 20. I’ve set things up in F20 just like I did in previous Fedora’s.

I am using a dual head setup. Screen 1 is the display on my laptop and screen 2 is an attached monitor.
Kernel version is 3.12.8-300.fc20.x86_64
NVidia driver version 331.20 (from rpmfusion)

01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1)

First issue is that gdm login screen has my displays in the wrong order (monitor is left of built in display instead of right of). Just annoying when the mouse appears on the screen that the login stuff is not located on. This was never an issue in previous Fedora’s

Second issue is much worse for me. Apparently all Quake 3 based games (ioq3, Reaction, iortcw and co.) no longer display anything. When I launch them, the screens go black but I hear the games running. Even tho the screens are black, I can hit the console key (pull down the game console) and type quit and then the game exits and the screens come back to life.

Quake 2 works like a charm. Quake 3 based games print lots of info into their consoles during startup and I get no errors there from the game. But I do see strangeness in dmesg:

[36214.285971] ACPI Warning: _SB_.PCI0.PEGP.DGFX._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)

two or three lines like that for every startup attempt. No errors in Xorg.0.log. I do get some warnings:

[ 44.111] (WW) “glamoregl” will not be loaded unless you’ve specified it to be loaded elsewhere.
[ 44.111] (WW) “xwayland” is not to be loaded by default. Skipping.
[ 45.482] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 47.473] (WW) NVIDIA(0): UBB is incompatible with the Composite extension. Disabling
[ 47.473] (WW) NVIDIA(0): UBB.
[ 47.928] (WW) NVIDIA(0): Option “TwinView” is not used

My Xorg.conf is a bit specific. To avoid games centering themselves between my monitors I have:

Section “Screen”
Identifier “Screen0”
Device “Videocard0”
Monitor “Monitor0”
DefaultDepth 24
Option “TwinView” “1”
Option “metamodes” “DFP: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0; DFP: NULL, CRT: 1440x900; DFP: NULL, CRT: 1280x1024; DFP: NULL, CRT: 1024x768; DFP: NULL, CRT: 800x600; DFP: NULL, CRT: 640x480”
SubSection “Display”
Depth 24
EndSubSection
EndSection

This means that for resolutions 1440x900, 1280x1024, 1024x768 and 800x600 the built in display gets switched off leaving only the bigger external display for the games to use. This setup has worked fantasticly for years now.

I’ve tried compiling new versions of all the Quake3 based games from their github repos and this still changes nothing. Can anyone please help me figure out what is going on?

Thanks in advance,
JBravo.

Same problem here. Happened after upgrade to FC18. Quake3Arena staggers and is sluggish and has lost all color. I can still see all the surfaces but they have been replaced with shades of black.

I see no proper info here

https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

sorry. same as above except newer kernel 3.14.8, single monitor and rpmfusion standard xorg.conf file. I am not finding errors in any log or output. I just played with Gamma settings and saw no difference.

http://76.187.107.244/nvidia-bug-report.log.gz

meant to add. I had no problem at all with driver version 310. Both 319 and 331 give me this problem.

OK, playing with quake3 settings, I see normal lighting with the Vertex setting and goes back to dark if I choose “Lightmap” setting. In the cfg file, Lightmap means “dynamiclight”

Turning off “GL Extensions” in the game also restores the lighting even with LightMap enabled.

You need to set grub to text mode to prevent vesa from loading as it conflicts

[  117.429546] nvidia 0000:06:00.0: irq 49 for MSI/MSI-X
[  118.250296] NVRM: Your system is not currently configured to drive a VGA console
[  118.250303] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[  118.250307] NVRM: requires the use of a text-mode VGA console. Use of other console
[  118.250310] NVRM: drivers including, but not limited to, vesafb, may result in
[  118.250312] NVRM: corruption and stability problems, and is not supported.

The same goes for the glamoregl module.

*** /etc/X11/xorg.conf.d/00-avoid-glamor.conf
*** ls: -rw-r--r--. 1 root root 108 2013-11-07 08:09:54.000000000 -0600 /etc/X11/xorg.conf.d/00-avoid-glamor.conf
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "Module"
Disable "glamoregl"
EndSection

The rpmfusion nvidia packages do this for you.