Fedora 23 + xorg downgraded + nvidia 304xx driver = gnome-shell not working

Hi all. Ask your help for this very annoying bug.

Upgraded Fedora from 22 to 23.

Downgraded xorg from 1.18 to 1.17 F22, because nvidia driver does not work with xorg 1.18 as it is still RC.

Rebuilded nvidia kernel driver for GEForce 6 and Linux kernel 2.4.5-300 F23 with akmods and xorg 1.17. using akmod-nvidia-304xx-304.125-3.

Now gnome 3.18 starts in F23 with this latest kernel, but mouse is not working in gnome-shell. Can’t activate calendar, or other icons in top panel. Can’t start apps with the mouse from apps bar. Can’t switch workspaces. Can’t give focus to an app from the app list showed by windows key. I have to use only keyboard, and reboot through another terminal.

Moreover, any application main bar does not respond to mouse click. Can’t close application, or maximize it through button, or move it. Left or right mouse button is not working.

But the mouse is working inside applications. For example, I can use Firefox or Thunderbird without problem. Only application main bar is completely not responding to mouse clicks.

Only upper left angle in GNOME top panel responds to mouse pointer.

Disabled all gnome extensions - problem persists.

Started Gnome with root user - problem persists.

Started Gnome with Gallium 0.4 fallback video device - gnome-shell works normally with full mouse integration.

Any help or suggestion is greatly appreciated.

Thank you.

Nvidia-bug-report: https://paste.ee/p/trJbS#

I apologise if this seems rude, but, noone should use gnome. Ever. This is obviously a gnome bug.

Gnome have been going downhill for a long time, but now they’ve removed the tree-view sidebar in the nautilus file manager, Gnome can only be regarded as an obscene joke. It is no longer a suite of software which is usable by anyone to accomplish any task. It is a complete waste of time. Fullstop.

Switch to Xfce, or Enlightenment (with compositing disabled) now, and I’m pretty sure you’ll find your mouse works fine.

It may or may not be an Nvidia bug. However, I had the same problem and the fix was to switch from the 304xx to the 340xx akmod drivers. So there is a bug (or quirk) that allows 340xx work with Gnome and causes 304xx not to work with Gnome.

In order to track this down, we need an answer to “what’s different between 304xx and 340xx that could explain this.” Once we know this, then a bug can be assigned to the appropriate project.

Hope nvidia can help get the ball rolling. Thanks.

Confirm the fix changing Nvidia akmod drivers from 304xx, as @ephae signals.

Using this temporary solution:
https://ask.fedoraproject.org/en/question/77996/fedora-23-nvidia-gnome-shell-mouse-not-working/?answer=78031#post-id-78031
solved this issue by now.

Just a note. If you downgrade xorg, you need to downgrade the xf86 input drivers as well (xf86-input-evdev, etc…) otherwise your mouse and/or keyboard may stop working under Xorg/gnome. Those things needs to be built against the running X server.

Confirm this whith Gnome Shell 3.18(Arch Linux) + 304 driver. With 340 driver mouse working. Probably it’s a problem with Gnome Shell, bacause early with 3.16 all worked.

Hi,

It is not just fedora with gnome but any gnome based DE. Most likely a bug with the nvidia-304xx proprietary driver.

I’m using Archlinux. I had used this driver (nvidia-304xx) since it was available with a xfce install without any issues but wanted to switch to a more modern environment. With a fresh install, I installed budgie-desktop which is heavily dependent on gnome. At first everything went okay using the nouveau driver, but my laptop ran unusually hot at 72C idle.

Reading the arch forums, the general recommendation was to use the proprietary drivers. Installed the nvidia-304xx and hell broke loose. It seemed to work, opening applications like a file manager, system monitor or web browser worked, but opening a terminal would freeze the window (couldn’t drag it around) eventhough keyboard input would still go through, to finally freeze entirely after a while. Although the mouse cursor could be moved, no click event registered. Weird thing was that trying another environment, openbox in my case, worked without any issue and with a more reasonable temperature at 55C.

Doing a couple of reinstalls and trying different DEs, it seemed a bug with budgie-desktop. Because it is a new desktop environment I thought it was the culprit, until I found this thread.

After wasting a couple of days, I’m disappointed but glad I now can work towards a solution. I understand it is not the best commercial interest of nvidia to support old hardware. Luckily my card seems to just made the cut for the 340xx so will give it a try. If it doesn’t work, I just will return to good old xfce.

It is not very nice to say ‘hurr hurr gnome is trash, just use something different’. It is more productive to push for a solution rather than just whine. Sad to see the issue ricochet from X, to gnome, to nvidia and no solution for this bug.

Cheers.

x86_64 Linux 4.2.5-1-ARCH
xorg-server-common 1.18.0-3
nvidia-304xx 304.131-2.1
gnome-desktop 1:3.18.2-1

CPU: Intel Core i7 CPU Q 720 @ 1.6GHz
GPU: GeForce GT 330M

I was able to follow the guide at http://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/ to get the latest driver installed without issue. At the time that I’d tried I was running into issues with the latest nvidia driver not working with the version of xorg included with Fedora 23 but that’s since been resolved and the guide has been updated.

thats why I wont use Fedora 23 for my home machine. plus they have very poor repositories compared to what debian/ubuntu opensuse manjaro/arch/aur has. plus no such additional things reps like playdeb getdeb ppa launchpad aur trinity.

and that is a problem for me, I also has found problematic to install these blob on Debian cause of same long procedure and in the end it is just ruining whole kernel after reboot. I did the same procedure on OpenSUSE and zero problems I mean nvidia sh binary package driver installation and it works fine, but Debian just renders in none boot-able unrecoverable state. And when I saw almost the same guide on Fedora to install these binary blob I just scared enough and run to Ubuntu or Manjaro/Arch…cause I think Debian/Fedora has the same problem I mean you should always remove nouveau manually. Nouveau itself not a problem I even run few games and they are fixed up screen lock for gtx580 after booting to desktop. I even play few games with nouveau and almost has had no lags with this. But really I just wont follow Debian driver package installation experience cause it just destroy whole system for me. It’s rather not a Debian or Fedora problem from these companies point but nvidia binary blob. For me they are right cause they writing and compiling whole OS + kernel. And if they said that nvidia implements wrong unsafely way to provide drivers for their OS they are probably right by design. But these complains have nothing to do with US NVIDIA patents.