Fedora 33 with latest kernel & nvidia versions flickering badly


After a fresh installation of fedora 33 (previously had 32 fully working) and getting Nvidia driver, I get a lot of screen artifacts and flickering.

Here are some details:

[andreit@localhost ~]$ uname -a
Linux localhost.localdomain 5.10.6-200.fc33.x86_64 #1 SMP Mon Jan 11 20:05:21 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

[andreit@localhost ~]$ lspci |grep -E "VGA|3D"
01:00.0 VGA compatible controller: NVIDIA Corporation TU106BM [GeForce RTX 2060 Mobile] (rev a1)

[andreit@localhost ~]$ nvidia-installer -v |grep version
nvidia-installer:  version 460.32.03

Here’s the report:
nvidia-bug-report.log.gz (893.5 KB)

I tried to install the driver in two ways:

  1. Fedora 36/35/34 NVIDIA [515.65.01 / 510.85.02 / 470.141.03 / 390.154 / 340.108] Drivers Install Guide – If Not True Then False → followed it in fedora 31/32, and it worked every time
  2. Howto/NVIDIA - RPM Fusion → produces same result

Another thing I tried is to completely remove any Nvidia driver and run with intel only. That worked fine, except I can’t change the brightness of the screen (100% permanently).

I’m running in dual boot with windows 10 (no issues, latest nvidia driver).

Is there any solution to this?

Do you also get the flickering in older driver versions (e.g., 455.55.01)?

Because I do also experience flickering (see Flickering with 1080 Ti and 460.32.03 driver), though for me it’s strictly just with the latest driver (460.32.03).

The last driver installed and fully working on fedora 32 was 450.57. After upgrading to fedora 33 and installing 460.32.03, I got the flickering, so uninstalled 460 and tried to install 450, but it failed with the latest kernel, so I had no choice but to reinstall 460.

Managed to install version 450.102.04 and the flickering is gone. I’m gonna stick with this version for now.

1 Like

You’re not alone -

Fedora 33 - 2080 Super Max Q - 460.32.03