Few Linker Errors

I have my environment variables set, im using VS2005 Professional and it is able to find cuda.h

I have the in project propertes linker->input as “cudart.lib cutil32D.lib” and i get the following linker errors

1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaFree@4 referenced in function _main
1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaConfigureCall@32 referenced in function _main
1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaMemcpy@16 referenced in function _main
1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaMalloc@8 referenced in function _main
1>incrementArrays.obj : error LNK2019: unresolved external symbol ___cudaUnregisterFatBinary@4 referenced in function ___cudaUnregisterBinaryUtil
1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaSetupArgument@12 referenced in function ___device_stub___globfunc__Z22incrementArrayOnDevicePfi
1>incrementArrays.obj : error LNK2019: unresolved external symbol ___cudaRegisterFunction@40 referenced in function ___sti____cudaRegisterAll_50_tmpxft_00000928_00000000_6_incr
ementArrays_cpp1_ii_54bfc6dd
1>incrementArrays.obj : error LNK2019: unresolved external symbol ___cudaRegisterFatBinary@4 referenced in function ___sti____cudaRegisterAll_50_tmpxft_00000928_00000000_6_incr
ementArrays_cpp1_ii_54bfc6dd
1>incrementArrays.obj : error LNK2019: unresolved external symbol _cudaLaunch@4 referenced in function “enum cudaError __cdecl cudaLaunch(char *)” (??$cudaLaunch@D@@YA?AW4cudaError@@PAD@Z)

ignoring all the crud in the errors, where is cudaFree, cudaMalloc, etc… defined?

thanks