Ffmpeg not working in DeepStream images based on Ubuntu 20.04

• DeepStream Version: 6.3
• TensorRT Version: 8.5
• NVIDIA GPU Driver Version: 535
• Issue Type: bug

I ran the DeepStream 6.2 container with:

docker run -it --rm nvcr.io/nvidia/deepstream:6.2-base

Then, I installed ffmpeg:

apt update && apt install -y ffmpeg

I get the following output when running ffmpeg:

root@4c8f7b12c919:/opt/nvidia/deepstream/deepstream-6.2# ffmpeg
ffmpeg: error while loading shared libraries: libavcodec.so.58: cannot open shared object file: No such file or directory

Why are ffmpeg dependencies not installed in the new DeepStream images?

Because the purpose of this image is to provide the runtime of gstreamer and deepstream.

At the same time, gst-libav also depends on libavcodec.

This is to avoid conflicts

You can run user_additional_install.sh in /opt/nvidia/deepstream/deepstream.

Then install the ffmpeg.

It will be works, I have tried.

I worked for me too, thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.