ffmpeg NVENC Encoding with -flags:v +ildct shows “No NVENC capable devices found”

So far I use NVENC with ffmpeg for all my encoding successfully. Today I got a new Zotac nVidia GEForce GTX 1660 6GB card.

I get “No NVENC capable devices found” error from ffmpeg. Only if I use -flags:v +ildct flag. Without ildct flag no issues except the output is progressive.

I 100% need Interlaced output and I tried most of the Interlaced flags like, -vf tinterlace=interleave_top,fieldorder=tff -x264opts tff=1 Nothing is giving me Interlaced output except -flags +ildct But with “Zotac nVidia GEForce GTX 1660” ffmpeg shows:

No NVENC capable devices found

I even tried all latest nVidia drivers. Nothing helped me.

My pseudo ffmpeg command line is as below:

ffmpeg -i SourceFile.mkv -codec:v h264_nvenc -preset:v slow -flags:v +ildct+cgop -s:v 1920x1080 -ac 2 -ar 48000 -codec:a mp2 -b:a 384k -r 25 -f mp4 -y NewFile.mp4

Is it a bug with nVidia driver or ffmpeg ? Is latest nVidia Turing technology doesn’t support Interlaced (very Bad) ?

Could some one help me ?