ffmpeg using hardware gpu (cuda)

@Jocover. Thank you so much!!!

It will be great to see hardware scaling into this project, unfortunately my C/C++ Skills are not to the level required, but I can help in other ways to keep this project going…

Also, I just reported a couple of bugs that came from 32.2 and 32.2.1.

https://devtalk.nvidia.com/default/topic/1057099/jetson-nano/gstream-nvv4l2h264enc-b-frames-display-ordering-is-not-right/post/5399244/#5399244

https://devtalk.nvidia.com/default/topic/1056596/jetson-nano/omxh264dec-nvv4l2decoder-34-7mb-per-minute-memory-leak-crash-when-decoding-interlaced-h264-video/post/5399230/#5399230

Your effort is also affected by those two bugs H.264 bFrames timestamps and H.264i Video Decoding wrong timestamps as it looks they are interpreted as a 2X or fields rather than considering the new rate after converted to progressive video.

In any case. THANK YOU SO much! and again, please let me know how I can help!

sorry for my bad english i have managed running ffmpeg with cuda support and libfdk-aac

nano /etc/enviroment

add /user/local/cuda/bin: on the beginn of this file

then compile avisynth usw

git clone https://git.videolan.org/git/ffmpeg/nv-codec-headers.git

sudo make install sudo ldconfig

./configure --enable-shared --enable-cuda --enable-cuvid --enable-nvenc --enable-nonfree --enable-libnpp --extra-cflags=-I/usr/local/cuda/include --extra-ldflags=-L/usr/local/cuda/lib64

git clone mpv

./bootstrap

./waf configure --enable-libmpv-shared --enable-egl-drm --enable-gl-x11 --enable-egl --enable-sdl2 --enable-ffmpeg-strict-abi --enable-xv

./waf install

all running

Spooky

@jocover Hello, super work, doubled my frame rate on the jetson nano.