FFTW 3.3.8 and PGI 19.1

The release notes for PGI 19.1 claim there is a page for building FFTW 3.3.8 but links to a page that only has instructions for PGI 12.1 and FFTW 3.3.2. Using those, I tried

export CFLAGS="-fast -Minfo -fPIC"
export FFLAGS="-fast -Minfo"
export CC=pgcc
export F77=pgfortran
./configure --prefix=/sw/arcts/centos7/stacks/pgi/19.1/fftw/3.3.8
–enable-shared --enable-threads --enable-openmp
CC=pgcc FC=pgfortran F77=pgfortran
make -j 4
make check

whereupon it hangs.

This is on CentOS 7, 3.10.0-1062.9.1.el7.x86_64, Intel® Xeon® Gold 6140 CPU @ 2.30GHz.

I tried that using both the LLVM and the no LLVM versions; same results.

I have also tried with --with-avx, --with-avx2 (configures but doesn’t build), and the above without specifying.

Are there actually instructions for more recent versions of PGI and FFTW available somewhere?

Thanks, – bennet

Hi Bennet,

Try using gcc instead of pgcc to build. The ASM code for “getticks” in “kernels/cycle.h” is incorrect for use with LLVM, which in turn causes the hang. Also, LLVM doesn’t yet have support for the AVX intrinsics, so even if we fix the ASM problem, the performance is poor relative to GNU. We’ve been working with the LLVM community to get this resolved, but for the time being it’s best to use gcc.

Hope this helps,
Mat