fftw --enable-sse2?

Hello,

I’m trying to compile fftw 3.0.1 with the PGI compilers. Is there a FAQ somewhere that explains how to get the --enable-sse2 switch working?

right now the options i use are:
./configure CC=pgcc --enable-threads --enable-float --enable-shared
CFLAGS="-O3 -fastsse -Mvect=sse -tp k8-64"
F77=g77
FFLAGS="-O3 -m64"

but i would like to use F77=pgf90 and --enable-sse2
any tips are welcome…

Hi boukeB,

If I remember correctly, the FFTW build option “–enable-sse2” uses extended asm statements to include the SSE2 instructions. While we are adding this feature for the 6.1 release, we currently do not support extended asm statements. However, the “-fastsse” option generates SSE2 instructions by default so I don’t believe you actually need to use “–enable-sse2” at all.

Hope this helps,
Mat