File format not recognized

I tried to compile a source code with the debugging options but I faced the following error:

cuda64/bin/nvcc -g -G -I sdk64/common/inc -L sdk64/lib -lcutil -o bin.debug
/tmp/tmpxft_0000168d_00000000-11_tmpxft_0000168d_00000000-6_ptxvars.sm_10.cubin.dwarf.o: file not recognized: File format not recognized
make: *** [dtc.debug] Error 255

/tmp/tmpxft… did not exist.
If I compile it without -G option, no error occurred. So I guess something is wrong related to -G option.
I’m using OpenSUSE 11.0 (x86_64), version of nvcc is as follows:

% nvcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2009 NVIDIA Corporation
Built on Thu_Apr__9_05:05:52_PDT_2009
Cuda compilation tools, release 2.2, V0.2.1221

Does anyone have any idea to solve this problem?

I found that I was using the 32-bit version of “ld” command because of wrong $PATH.
This problem fixed.