"File System and OS" Error in Jetpack 4.5.1 Linux for Jetson Nano


I am writing to inquire about an installation error I have received when trying to install software components for the Jetson Nano. I have been working to install host and target components for the “Jetpack 4.5.1 Linux for Jetson Nano (Developer Kit Version)” on an Ubuntu 18.04 OS. However, I am receiving an error for the “File System and OS” installation, which is causing other target component installations to fail as well. I have attached screenshots of the summary finalization menu (expanded) and the terminal tab errors. I’d appreciate the support in resolving these errors to enable installation of the remaining target components.

The version of SDK Manager is SDK Manager

Thank you.
Abir MuhuriJetson Nano_SDK Manager Errors.pdf (1.0 MB)

hello abirmuhuri,

could you please gather logs for reference since it’s shown dependency errors,
please also access SDK Manager User Guide,
you may check Repair and Uninstall session for some tips to fix installation errors.

Hello Jerry,

Thank you for the response. I have gone through the steps in the “Repair and Uninstall” page but have not been successful. As requested, please see attached for a zip file contain all logs for the Jetson Nano Installation errors. I have also attached logs for the Jetson Xavier NX which has failed as well.

Please let me know if any additional information is required.

SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_Nano_[developer_kit_version]_2021-03-24_10-44-35.zip (259.5 KB)
SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_Xavier_NX_[developer_kit_version]_2021-03-24_10-19-38.zip (100.7 KB)

hello abirmuhuri,

there’re shown errors, Due to its dependencies fail to install for several packages. such as Multimedia API, CUDA Toolkit, TensorRT…
please refer to Flash agx firmware - #13 by JerryChang, please review the sources.list, you may have a try to update it to resolve download failure.

Hello Jerry,

Thanks for the response. I reviewed the sources.list as you recommended and tried to update using the “deb” command but was not successful. Instead, I ran the “software updater” on my ubuntu OS to check for updates and installed any remaining updates.

After updating, I noticed another error having to do with my ethernet internet connection. I plug in an ethernet cord to my Jetson Xavier, but repeatedly see that the “network connection is not activated.” Furthermore, I’m seeing a slightly different set of error commands from before. Please see attached for the fully exported logs. I’m wondering whether the failed internet connection (directly to my Jetson) is causing the install issues.
SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_Xavier_NX_[developer_kit_version]_2021-03-26_11-07-47.zip (111.0 KB)

hello abirmuhuri,

are you choosing a correct target board,
it seems you had tried to install an image with Jetson Xavier NX
for example

*** Install summary of 15 components ***
        Install details:
- NV_L4T_DRIVERS_T194_COMP@JETSON_XAVIER_NX_DEVKIT: Failed - 00:04:31 -start: 11:11:10 GMT-0400 (Eastern Daylight Time) - end: 11:15:41 GMT-0400 (Eastern Daylight Time).
- NV_L4T_FILE_SYSTEM_AND_OS_T194_COMP@JETSON_XAVIER_NX_DEVKIT: Failed - start: none - end: none.

Hi Jerry,

Yes I am trying to instal on both the Jetson Nano and Jetson Xavier NX (both target boards). This error is for when I specifically connect the Jetson Xavier NX for installation (which is marked as “detected” when I connect).


hello abirmuhuri,

let’s have two steps verification to narrow down the issue,
(1) were you able to download and install JetPack release image via SDKManager, please complete image installation and check ~/nvidia/nvidia_sdk/JetPack_version_platform/Linux_for_Tegra/
(2) is there a specific flashing error even with the flash.sh command line. please share the whole command line and error messages for reference,

Hi Jerry,

Here are the outputs I receive:
(1), I checked the JetPack release image error by clicking the “Install Error” for “Drivers for Jetson” under “Jetson OS image.” The screenshot of the error i selected and terminal error message are attached.

Jetson OS Image_Install Error (1.8 KB)

(2). I’m not sure I understand what you mean by the flash.sh command line? I tried entering the following command line per the Linux developer guide:

$ sudo ./flash.sh
The board and roodev in following <> are jetson-xavier-nx-devkit and mmcblk0p1 respectively.
However, I get this error:
bash: syntax error near unexpected token `<'

Alternatively, when I search flash in the terminal window, I see the following details regarding the Jetson Xavier NX installation.

Please also note that I had already flashed the OS on an SD card per online instructions. The SD is card is properly inserted into both Jetsons as well.

hello abirmuhuri,

please enter the JetPack release path, for example, ~/nvidia/nvidia_sdk/JetPack_version_platform/Linux_for_Tegra/
you may also check examples for using flash script. please exclude <> to specify the target.
there’re several flash configuration files, it contain the files that flash to each target.
you may enable the flash.sh to flash Xavier NX Devkit as following,
for example, $ sudo ./flash.sh jetson-xavier-nx-devkit mmcblk0p1

check developer guide, Flash Script Usage for reference.

Hi JerryChang,

Thank you for providing the “Flash Script Usage” guide for reference. After looking into it, it seems I was missing two earlier steps under “Setting Up Your File System” that are required before flashing:

Step 1: Set Up the Root File System
Step 2: Copy the rootfs to the Device

To begin, I place a jumper on the FC REC and GND pins on the back of the board. I also had an empty “rootfs” file to begin with under Linux_for_tegra after initial downloads that I had done (which I mentioned last time). However, when extracting the sample file system as suggested using: $ sudo tar -jxpf …/…/Tegra-Linux-Sample-Root-Filesystem_<release_type>.tbz2

I get the following error in my terminal window throughout the extraction process.

Next, I tried extracting the sample file system (Tegra-Linux-Sample-Root-Filesystem_<release_type>.tbz2) by right-clicking “Extract to” and selecting the rootfs folder. I then got the following error.

Sample_Root Extraction Error

I tried this also with the JetsonNano (sample root extraction by right-clicking) but I got an error as well.

Finally, when attempting to flash the Jetson using the command: sudo .flash.sh jetson-xavier mmcblk0p1, I get an error pointing to the rootfs directory. I’ve uplaoded the full terminal output below.

Please let me know what you recommended for troubleshooting this step prior to flashing. Thanks.Xavier NX Flash Error 04.07 (13.9 KB)

hello abirmuhuri,

why don’t you use the default JetPack release image for flashing?
it’ll save to your local host machine as following if you had install it via SDKManager,
i.e. ~/nvidia/nvidia_sdk/JetPack_version_platform/Linux_for_Tegra/