finding the right driver

I’m dual booting Windows 10 and Centos 7.

And, since my NIC is excluded by VMWare from its general ESXi 6x support, I’m using Oracle’s VirtualBox as a workaround; until I figure out a better solution. The workaround that I’ve seen (for using an alternatively named driver) looks a little too complex.

I’m hoping that the one driver that runs with Windows 10 will also be adequate for Centos 7 as well.
However I’m not necessarily expecting this to be the case.

I haven’t tried it yet. But I plan to put the card in place some time tomorrow; not tonight. I just received the EVGA GEFORCE GT 740 in the mail a little while ago.

The UPS fellow left it on our doorstep without ringing the doorbell. A neighbor had to tell me it had arrived. And I’ve been busy looking at other things since then.

Provided that the Windows driver doesn’t properly power the Centos 7, which driver should I download for the Linux side? Please give the URL in your answer with the number of the driver.

Also, if I’m using Centos 5, 6 or 7, will I use a different driver? I would love to dual boot Solaris 10, Windows 10 and all three versions of Centos. But it seems a little too complex. I would love to get the ESXi 6x option working. But I need to focus on getting my next job instead.

I know that I’ve given you WAY too much information. But I thought that maybe you could offer something beyond just the driver number and URL in return. Just a thought.

http://profoundstates.com

I forgot to say that I’m running a Gigabyte GA-Z97-HD3 motherboard with a 3.40 gigahertz Intel Xeon processor. I don’t know if any of this makes a difference. But I thought that I would throw it in just in case.

Oh, and please respond to yoda226us@gmail.com; as I get really busy looking for work; and may forget to check back with this forum.

If there’s anything that I can throw in, that you need, additionally, to come up with the correct answer, please let me know.

I downloaded the Linux-x86_64 (352.63) driver and attempted to install it in Centos 7.

I have the EVGA Geforce GT 740 graphics card.

First I checked to make sure that the Nouveaux driver wasn’t installed. It didn’t show up in memory.

Using the installation instructions at http://www.dedoimedo.com/computers/centos-7-nvidia.html I ran the .run file, from the command line, with root, and got an error saying that it didn’t detect any driver card supported by the 352.63 64 bit driver.

Even after this error it allows me to continue with the installation. So I go forward hoping it’s going to work anyway.

I checked at http://www.nvidia.com/download/driverResults.aspx/95159/en-us and found that the
GeForce GT 740 (my new card) IS listed as a supported card for the 64 bit 352.63 driver.

Next I get the ERROR: Unable to load the kernel module ‘nvidia.ko’ This happens most of the frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is uspported by this NVIDIA Linux graphics driver release. Please see the log entries ‘Kernel module load error’ and ‘Kernel messages’ at the end of the file ‘/var/log/nvidia-installer.log’ for more information.

This is my first NVIDIA driver and nouveau doesn’t appear to be installed. And this card, according to NVIDIA’s web site IS supported by this driver.

Thinking that I needed to reboot, after updating the system with yum, and this might help, I rebooted and attempted the installation a second time. It failed the second time also.

So I went and checked out the installation log /var/log/nvidia-installer.log to see if I could find something there. I did. It says “ERROR: Kernel configuration is invalid.” “include/linux/autoconf .h or include/config/auto.conf are missing.” Run ‘make oldconfig && make prepare’ on kernel src to fix it."

I will see about going through this process.

Any clues to assist me in moving forward with this graphics card, with Centos 7, would be appreciated. I don’t want to return it.

yoda226us
http://profoundstates.com

Also, I could have sworn that I was running Centos 7. But when I boot it definitely shows Centos 5. I know this isn’t your responsibility. But if you have any ideas, other than, he chose the wrong file, let me know.

Well first of all, you mentioned about virtualization. So are you running CentOS 7 in a virtual machine (like with VirtualBox or whatever)?

If you are you mostly do NOT install the nvidia driver (unless you doing some VGA passthrough with IOMMU) but whatever virtual driver necessary. For example, vboxvideo.ko (kernel module) and vboxvideo.so, vboxvideo_dri.so (Xorg DDX driver) for Virtualbox, and surely there might be some host side kernel modules needed to be loaded for any expected functionality.

If you are not running CentOS in a VM, but a physical machine, you probably have got the right driver package from nvidia but I think you better list the actual steps you’ve taken to install it and attach the installer log here instead of giving us a line you find interesting in it. Otherwise we can hardly have any idea on what’s going on.

By the way in both case you’re likely to need the header/devel package of the kernel you’re using since it’s needed for building out-of-tree kernel modules (both vboxvideo and nvidia are examples).

As for the version confusion of CentOS, can you tell where EXACTLY you saw it shows “CentOS 5”? Bootloader entry or what? Have you ever got a CentOS 5 ISO and/or installed it once to the same (logical) machine where CentOS 7 is assumed installed?