Firefox 80 EGL and WebRender does not work

  1. Download Firefox nightly
  2. Start firefox
  3. Go to about:config address
  4. Enable config gfx.webrender.all
  5. Close firefox
  6. Start firefox with MOZ_X11_EGL=1 env. variable
  7. Firefox does not render anything

I can confirm the issue.

Using nvs295 with 340.108 driver on Fedora 32, Released Firefox 80.

  1. env MOZ_X11_EGL=1 firefox
  2. Opens firefox window with empty content that I can see wallpaper in it. The errors in the console:
    [GFX1-]: Failed to create EGLContext!: 0x300c
    [GFX1-]: Failed to create EGLContext!: 0x300c

This still appears to be an issue.

With the latest Firefox release (90.0), and the latest beta Nvidia drivers (470.42.01), it no longer seems to be necessary to force enabled the GPU accelerated WebRender compositor.

This is what the relevant parts of the Firefox about:support page look like, before editing any pertinent settings:
image

Non-software Webrender appears to be used, without forcing anything, but EGL isn’t being used.


Since EGL has been disabled by default in this configuration, I opted to force-enable it by running:

MOZ_X11_EGL=1 firefox

which printed the following errors:

[GFX1-]: Failed to create EGLSurface!: 0x3009
[GFX1-]: Failed to create EGLSurface
[GFX1-]: Fallback WR to SW-WR
[GFX1-]: Failed to connect WebRenderBridgeChild.

Indeed, it has fallen back to software rendering and so, in effect, EGL is still not active.


I’m using Arch Linux with Nvidia driver version 470.42.01 built from nvidia-all, with Firefox 90.0, and a GTX 1050 Ti.

Try firefox nightly, one or more EGL bugs were fixed in FF

Yep! EGL seems to work just fine on Firefox Nightly with MOZ_X11_EGL=1 firefox. Thanks.