First Boot Doesnt Happen

Hello Community -

I am a windows developer and mostly Linux literate, but do not do it everyday … as of yet. I purchased two Jetson Orlin Nano Development Kits. I have closely followed the startup instructions as seen on Jetson Orin Nano Developer Kit Getting Started Guide | NVIDIA Developer.

With my Windows Machine I have downloaded the recommended linked image as well as the SD Formatter and Etcher links as directed in the startup instructions.

I installed the SD formatter and performed a quick format as directed. I have also tried an over write format. The file system is exFAT and I see 59.45 GB of capacity. I then performed the etch as instructed (targeting the zipped file image,) and even let the verify happen. The etch is verified. I even tried to etch the decompressed image, but it didnt help.

I then insert the SD Card (it only goes one way) and power the Nano.

I get the following message … ** Warning Test Key in Use ** and then it prints mapping and falls into the shell.

When I check the boot manager menu, the UEFI SD Device is selected. When attempting to boot without an SD card, the dev system goes through all the network boot options too.

Since when the SD card is inserted, the Dev System doesnt try to use network booting, I can conclude that the SD card is detected and it is looking for a boot instruction.

The Software Image may not be complete I supose, and it cannot find a startup script, (or a valid license key?) to take me to the EULA as advertised.

I get the exact same results on both Nano’s with verified etched SD Cards of 32, 64 and 126 GB. Can someone please help.


do you any log with UART?
Please try to flash the device with SDK Manager or scripts provided in our BSP, as if the issue lies in the internal QSPI memory (UEFI, uboot, things like that), flashing only the SD card does not help no matter how many times you try.

Thank your community for your helpful advice. Here is what I did to avoid the problem.

  1. I used a 64 GB Samsung SD.
  2. I did an Erase Format on the SD Formatter.
  3. I did a Verify after Etch (no different than before)
  4. I redownloaded the image link. This time it was 3 GB smaller. Weird.
  5. When booting after warning using test key it said attempting an Lt boot (paraphrased)
  6. I am in :-)
  7. See you at the salt mines

Just like I said, unlike other Jetson products which requires to be flashed with SDK Manager, you can usually get your Jetson Nano to work after only flashing SD cards with tools like Etcher.

But if something goes wrong with the QSPI memory on the module (like the bootloader in your case), then the only way to fix it is to re-flash with SDK Manager.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.