"First-chance exception.... cufftResult_t at memory location ...."

Hi all,

after i made the update of CUDA from the version 4.0 to the last version 5.5, my Programm is no longer running.

i get the following error message:

First-chance exception at 0x7619c41f in Schicht.exe: Microsoft C++ exception: cufftResult_t  at memory location 0x0045f62c..

i get the same error message three times at different memory locations.

may be this caused by a wrong lib-path in the linker? i think, the programm has a wrong path to the cufft.lib.

thanks in advance for your help.

Hi all,

here some more Informations about this error. I run the Programm with debug-mode.
The error is related to the use of CUFFT.

With CUDA 4.0 worked the programm fine. Now with CUDA 5.5 i get this error.
What are the differences between CUDA 4.0 CUFFT and CUDA 5.5 CUFFT ?

Here you find my code for the FFT transformation.

cufftReal *d_Ref;	// Cuda Reference
	cufftComplex *d_fftRef;	// Cuda FFT of the Reference


	cudaMalloc((void**)&d_Ref, sizeof(cufftReal) * numData);
	cudaMalloc((void**)&d_fftRef, sizeof(cufftComplex) * numData);


	cudaMemcpy(d_Ref, RefValues, sizeof(float)*numData, cudaMemcpyHostToDevice);


	cufftHandle planForw;
	cufftPlan1d(&planForw, numData, CUFFT_R2C, 1);
	cufftExecR2C(planForw, d_Ref, d_fftRef);
	cufftDestroy(planForw);

Have a look at this link http://blogs.msdn.com/b/davidklinems/archive/2005/07/12/438061.aspx to know more about first-chance exceptions.

The exception you are notified (first-chance exception) should have been caught and handled properly by the CUDA libraries. You say that the program is no longer running, but I guess your application should run correctly anyway. This notification is typical of Visual Studio and under other IDEs you would not observe it at all. I don’t think you should worry about this message.