First configuration of the jetson nano 2GB


I hope you are doing well. I am currently facing a significant issue with my Nvidia Jetson Nano 2GB, which I recently acquired for a project. I followed the official guide for the initial configuration, but I am encountering a major problem when attempting to flash the image onto the SD card.

Specifically, I used BalenaEtcher to flash the image onto the SD card. The flashing process itself seems to go smoothly, but during the validation process, the SD card gets divided into multiple partitions. Furthermore, numerous pop-up messages appear on the display, prompting me to format the disk. When I click on cancel, an error message pops up stating: “le volume ne contient pas de système de fichiers connu. Veuillez vérifier si tous les pilotes de système de fichiers nécessaires sont chargés et si le volume n’est pas endommagé.” (Translation: “The volume does not contain a known file system. Please check if all necessary file system drivers are loaded and if the volume is not damaged.”)

I would like to highlight that I have tried formatting the SD card before flashing the image. I attempted formatting it once with FAT32 and then with Ext4, but the problem persisted.

Additionally, when I connect my HDMI cable to the Jetson Nano, which I know is functional, nothing is displayed on the monitor. This occurs specifically after I insert the SD card into the Jetson Nano.

I kindly request your assistance in resolving this issue. Your guidance and support would be greatly appreciated.

Thank you in advance for your help.

Best regards,
Mohamed hedi


what OS are you using to flash the SD card? Have you tried with a different SD card?
Multiple partitions are something expected, but not sure why you got the warning.

I’d suggest flash your device with SDK Manager:

am on Windows , i flash the SD card with Balena Etcher , and yes tried with a different one but the probelem still the same . i cannot use SDK manager because am using windows . I need some help …


it’s very likely that bootloader stuff is damaged when a device fails to boot up, and it resides in the QSPI memory on Jetson Nano modules, which cannot be flashed with SD card images.
You may try virtual machines, but they are not guaranteed to work.

Or see if you can dump some log with serial connection:

hello, the problem resolved , but i got the same problem as that : i flashed this image : jetson-nano-2gb-jp461-sd-card-image , please provide me with the solution


have you tried JetPack 4.6.3?

no i did not , it will works for sure ? because downloading take too much time , please give me one that version that works for sur

We usually recommend using the latest release, and we will can debug more if it still does not work.

So i must download 4.6.3? Link please

There is no method to fix this by using sdcard image. You must flash your board with sdkmanager. Please get a x86 ubuntu host.

Thank you for your help , i flashed 4.5 image and it works finally


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.