First install of Jetpack 4.0 on Xavier difficulty (Solved)

Problem: executing ./JetPack-L4T-4.0-linux-x64_b188.run in terminal window gives error:

“Error: Jetpack must be run on a Ubuntu platform. Please check your platform and retry.”

I just received my Xavier and am attempting to follow the instructions in How to Install JetPack.
I have all the peripherals attached as described (I believe).
I am working from an Asus Laptop with USB3 and Linux Mint 18, Cinnamon desktop 3.0.

uname -a reports:

Linux marmoset-N550JX 4.4.0-134-generic #160-Ubuntu SMP Wed Aug 15 14:58:00 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Is a Mint install unsuitable for running jetpack? It is going to be a problem if that is so.

Dave

You could probably use an Ubuntu 16.04 live usb or CD to flash Jetpack onto the Xavier. You also may be able to manually copy the host installation files over to your Mint partition to install the host software after Jetpack downloads them to your Ubuntu live session.

Unfortunately JetPack must run on Ubuntu. If you just want to flash, then the driver package plus sample rootfs are sufficient on any Linux PC distribution (JetPack is a GUI front-end to other software and doesn’t do the actual flash).

Unfortunately, although a live DVD is a good idea, it won’t work. The kernels on the live DVD doesn’t have the required loopback support.

VMs typically don’t work due to issues with losing the USB. Some people do make them work, but they have to go through extra VM setup to make sure the USB is not lost as it re-enumerates.

Also, the file system type must be a native Linux type. If you were to run a DVD on FuseFS it would appear to flash correctly, but the end product wouldn’t work due to permissions being wrong. Same for external drives…if they are formatted as VFAT or NTFS they are not capable of preserving Linux permissions and won’t work.

Note that if you flash on command line it doesn’t prevent you from running JetPack at a later date and selecting to just install packages. on the other hand, if you have the dev kit, it already runs the new R31.0.1, so there is no reason to flash it (but a module without a dev carrier comes empty, and so that needs flash…so do modules going on third party carrier boards).

The R31.0.1 URL is here:
https://developer.nvidia.com/embedded/linux-tegra
…which happens to be what JetPack4 developer preview would download and use (JetPack would read a manfest, then download based on the manifest…but the manifest goes to the L4T content of R31.0.1 anyway).

Most people dual boot Ubuntu. The very latest JetPack4 preview adds host support for Ubuntu18.04, whereas earlier releases worked with 14.04 and 16.04.

You can also download and install individually, most if not all the software packages Jetpack installs for the host off the downloads site.

I have installed Jetpack4.0 on a fresh Ubuntu 18.04, Xavier target is up,
tried nsight on the host, it is not working readily as with Jetpack3.0 on TK1.
(This message is sent from the Xavier’s Chromium Browser)

About to drop back to Jetpach3.3/Ubuntu 16.04, I need nsight to explore Cuda
I noticed that the NVidia ethernet is not active/connected, could that be the problem
Anyone have the success story, please share. Thanks

I just created a tutorial on how to install JetPack 4.0 using a VM.

https://devtalk.nvidia.com/default/topic/1039549/jetson-agx-xavier/jetpack-4-0-install-with-a-vm/

@AerialRoboticsGuru: Thanks for the tutorial. I’ll give it a try. As I feared, I hosed my desktop trying to create a Linux/Linux dual boot. I’ll try a VMWARE from my functioning laptop tomorrow.

Dave

Virtualbox VM (autocorrect strikes again).

Dave