First login screen is not shown on primary display

Hi Nvidia:
I used a chip to convert one DP signal into two HDMI outputs.
In the settings, I set the display 1 as primary display.

However, after reboot, the login icon is not shown on the primary display. As you can see, the login icon is displayed in the left side, which is not the primary sceen.

Login and lock the screen, the login icon is back to primary display:

Please help.

Many thanks.

This looks not able to support. Our driver does not know there are 2 monitors there.
It is just one monitor to Jetson side.

Hi WayneWWW:
Thank you for your reply.
But xrandr can recognize DP-0.1 and DP-0.2 connected.
Maybe we can use xsession to correct it?
If so, which files/config should I modify? Last time I tried to use service to config xinput, it just return “Unable to open display”

Many thanks.

Please try to reproduce your issue on devkit so that we can check.

We are not able to answer your question now.

Hi WayneWWW:
This issue happens also on dev kit. But to reproduce the issue, another chip is required to do so.

I do believe it’s because of the xsession init settings. Are there documents about xseesions on jetson orin?
Especially the first stage of it?

Many thanks.

Please try to use DP MST adapter and 2 DP monitors to reproduce this issue. This is the only way we officially support.

There is no xsession document for any Jetson platform.

Hi WayneWWW:
We used another DP MST to reproduce our issue.
The MST got two outputs, DP 0 and DP 1. The issue is that the login screen will always shown on DP 0, even if we set DP 1 as primary screen.
If we switch the monitor, the login screen will still shown on DP 0, and primary screen settings remains.

Please help.
Many thanks.


Please try to change the primary setting in that monitors.xml and do the copy.

cp ~/.config/monitors.xml ~gdm/.config/

ex: <primary>yes</primary>

Hi WayneWWW:
Thank you very much. This do the work.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.