Flash back to factory settings


I just recently flashed my Jetson TX 1 in an attempt to install Jetpack, the reason that I tried this was to get CUDA/CUDNN working. However, this has left the Jetson in a state where I cannot login (as I posted about in another post).

Is there a way to reflash it to its factory state?


Not unless you cloned the image first or if I send you a cloned factory image (it’s 15GB).
Either way, it involves reflashing, and your login issue likely isn’t because of using Jetpack image or factory image.
Recommend trying to install Jetpack again or L4T directly.

Here’s a link to the other post: https://devtalk.nvidia.com/default/topic/914129/jetpack-install-problems-post-flash

Just wondering, when you say you can’t log in, what methods of connection have you tried? Is this ssh?

Login method was just restarting the board in non-recovery mode with a mouse/keyboard/monitor attached. It came up with a login prompt asking for username/password, but ubuntu/ubuntu didn’t work.

Anyways I think my next step will be to try the process again, but with a different network setup (everything connected together with ethernet on the same router).

Thanks for the advice!

An interesting thing…flash should not change the password. So long as the ssh port isn’t forwarded to a routable internet connection, I don’t think anyone could get in to change it. It could be useful to know what went wrong, but re-flash is very likely the easiest and quickest way to get past this.


I got the similar issue here.

My situation is that - I can go with tty1 - tty6, every commands or process worked fine.
When I switched to GUI, I saw the login prompt as usual, and it was sure I entered the right username and password.(ubuntu/ubuntu)There was no any error message on the screen.

However, after I clicked the enter key, the screen turned into black, flashed one time, then returned to the login prompt.

Before and after a login failure check “/var/log/Xorg.0.log”. See what new information is appeneded to the log after the login failure. It is more likely a video issue and probably not login failing (i.e., odds are that login succeeded and the GUI crashed…password is unlikely to be the problem). You could also check the change before and after for “dmesg | tail”.

You might want to try installing a different desktop environment (like LXDE) or, if that doesn’t work, try installing a different desktop manager (like GDM) to see if you can log in with that. This sounds pretty similar to issues I’ve seen when the default Ubuntu options, Unity and LightDM, have gotten misconfigured.