Flash Failure : Error in local apt settings

I am trying to Flash my Nvidia Jetson Xavier Agx Developper kit.
Unfortunently I get an error while trying to flash the device. I have tried several times but the smae problem seems to occur.

I am using Ubuntu 18.04

This is the main error message I get :
“Error in local apt settings”

Here are the error logs retrived with the NVIDIA SDK Manager :

SDKM_logs_JetPack_4.6_(rev.3)_Linux_for_Jetson_AGX_Xavier_modules_2021-12-06_21-10-38.zip (271.3 KB)

hello utilisateur743,

there’s SDKManager update recently, did you upgrade to the latest release version?
BTW, could you please deselect JetPack SDK components to only installing Jetpack release image for confirmation.
thanks

Hi JerryChang,

Thank you for the quick response.
Yes I checked and I do have the latest release version of the SDK Manager.

I have done what you asked, I got this error message :

Here are the new error logs :

SDKM_logs_JetPack_4.6_(rev.3)_Linux_for_Jetson_AGX_Xavier_modules_2021-12-07_09-26-53.zip (90.9 KB)

hello utilisateur743,

according to below failure, had you put device enter forced-recovery mode?

[   5.2096 ] Boot Rom communication
[   5.2123 ] tegrarcm_v2 --chip 0x19 0 --rcm rcm_list_signed.xml
[   5.2138 ] BootRom is not running

please see developer guide, To determine whether the developer kit is in Force Recovery mode.
please enter the command $ lsusb to confirm the device is detected. .
thanks

Hello,

Yes I have been specially carefull to put the device in forced-recovery mode.
Here is the output of the lsusb command :

Also I think it is important to inform you I am using the same device as on this post :

hello utilisateur743,

there’s JetPack release download to your local host, could you please perform flash script to flash the image manually.
for example, ~/nvidia/nvidia_sdk/JetPack_<version>_<platform>/Linux_for_Tegra/
you may also check Basic Flash Script Usage for the commands to flash the target, thanks

Hello,

I wasn’t sure which command I was supposed tu use to flash the device, I tried :

  • sudo ./flash.sh jetson-agx-xavier-devkit internal
  • sudo ./flash.sh jetson-agx-xavier-devkit external
    But both seem to stop at some point without success.
    Here are the terminal outputs :

internal command :
console.txt (56.9 KB)

external command :
terminal.txt (52.0 KB)

try this, $ sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1

I have tried this command as well which also seems to freeze at some point, I’ll send you the terminal output asap !

Hello,

It tried the command you suggested ( $ sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1), unfortunately the program seems to freeze at some point again.
Here is the terminal output :
flash_mmcblk0p1.txt (51.2 KB)

In general how much time does the flash procedure take ? To know how long it should let the program running before knowing for sure that it has failed.

After I interrupted the program I get this messages in the terminal :

^CTraceback (most recent call last):
File “./tegraflash.py”, line 1296, in
tegraflash_run_commands()
File “./tegraflash.py”, line 1155, in tegraflash_run_commands
interpreter.onecmd(command)
File “/usr/lib/python3.6/cmd.py”, line 217, in onecmd
return func(arg)
File “./tegraflash.py”, line 216, in do_flash
tegraflash_flash(exports)
File “/home/sebastien/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/bootloader/tegraflash_internal.py”, line 269, in tegraflash_flash
tegraflash_send_tboot(tegrarcm_values[’–signed_list’])
File “/home/sebastien/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/bootloader/tegraflash_internal.py”, line 2463, in tegraflash_send_tboot
uidlog = run_command(command, True)
File “/home/sebastien/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/bootloader/tegraflash_internal.py”, line 202, in run_command
log = print_process(process, enable_print)
File “/home/sebastien/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/bootloader/tegraflash_internal.py”, line 161, in print_process
output = process.stdout.read(1)
KeyboardInterrupt
Failed flashing t186ref.

hello utilisateur743,

the board communication should return within a second, then you’ll see the image creation and burning process, finally, reboot the board into ubuntuOS.
may I know what’s your environment setups? for example, are you using a virtual machine? is it a Laptop or desktop?

Hello,

I am using a laptop. I am using a virtual machine running Ubuntu (64-bit) version 18.04.
I got the virtual machine through the Oracle VM VirtualBox virtualisation tool.
.

hello utilisateur743,

this looks just like usb port forwarding issue, which usually related to your environment setups.
please try with native ubuntuOS as your x86 flashing machine environment, for the laptop platform, you should always have power-supply connected, may also try other usb ports for device connection.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.