Flash (for extern fs) fails. Can't find specific some files in rootfs


I’m currently trying to get the OS onto an external SSD (not M.2).
I followed the steps from ELinux:

  • Untar sample rootfs to new ssd formatted as ext4
  • Untar sample rootfs to the rootfs folder of the matching Linux_for_Tegra toolchain on my host (Ubuntu 18.04 Desktop VM with USB passed through).
  • Put the PARTUUID in the file bootloader/l4t-rootfs-uuid.txt_ext.
  • Reboot the device into recovery mode (the graphical SDK Manager also recognizes it)
  • Start flash with sudo ./flash jetson-agx-xavier-devkit external

I get the error that it can’t find the file etc/wpa_supplicant.conf which doesn’t exist. I first tried it with the most recent release of the Driver Package + Sample RootFs Jetpack 4.5.1 (at this time) and after that also with Jetpack 4.5.0.

Making recovery ramdisk for recovery image...
Re-generating recovery ramdisk for recovery image...
~/Linux_for_Tegra/bootloader/ramdisk_tmp ~/Linux_for_Tegra/bootloader ~/Linux_for_Tegra
30402 blocks
cp: cannot stat '/home/linux/Linux_for_Tegra/rootfs/etc/wpa_supplicant.conf': No such file or directory
failed command: cp -fv /home/linux/Linux_for_Tegra/rootfs/etc/wpa_supplicant.conf /home/linux/Linux_for_Tegra/bootloader/ramdisk_tmp//etc/wpa_supplicant.conf

Here is the log when I tried 4.5.0: https://transfer.cosmos-ink.net/mSX5j/log.log (the file has some nullbytes in it, so your text editor might complain).

Both seem to have the same error. When I create the wpa_supplicant.conf file I get complaints that a firmeware files is missing (lib/firmware or similar, not sure anymore). Those files seem to be renamed and I get the impression that the Driver Package isn’t in sync with the same sample rootfs.

I can’t find anyone with a similar issue and it doesn’t seem to be strictly a flashing issue or anything regarding the external drive either.

Can anyone help me out here? I just got the AGX Xavier Devkit (32 GB) today. I set it up fine over serial and it boots well from emmc, but I wanted to get it to boot at least the rootfs from an external SSD (currently a T5, but later a Samsung SATA SSD with USB-SATA-Adapter).

hello luna_devnvidia,

please refer to developer guide, Flashing to an External Storage Device for the instructions.

Thanks for the answer. I found that my mistake was to overlook running sudo ./apply_binaries.sh. Did this now, copied the new rootfs and the system booted!

Will try with an Ubuntu Base Image next to have some additional applications. If that doesn’t work, adding opkg should suffice.

Huge thanks!