Flash Jetpack 5.0.2 to SATA SSD

I am trying to upgrade a Xavier NX industial PC to Jetpack 5.0.2. The machine is sold by Seeed Studio but appears to be based around the A205 carrier board from Leetop. Documentation is very limited.

This machine includes a 256 GB SATA SSD attached to SATA ports on the board. It seems that it is exposed to the Xavier NX as a USB storage device.

I can flash to the internal eMMC memory without problem (using either SDK Manager or command line flash tools), and the Jetson will boot up and the SSD will be visible as a functional disk on /dev/sda1

However, I have not been able to install Jetpack 5.0.2 to this SSD using either the nVidia SDK Manager GUI or command line flashing tools.

Some of the approaches I have tried:

  • If I try to flash using SDK Manager with the USB storage device selected, it fails and reports that /dev/sda1 was not found.
  • If I try using SDK Manager with the “Custom” storage device and “./nvautoflash.sh --storage sda”, the host PC reports that the flash succeeded and the Jetson boots up, but Jetpack has been installed to the emmc (the SSD drive is visible as /dev/sda1 but unmounted).
  • If I flash using the command line approach instead (eg $ sudo ./flash.sh jetson-xavier-nx-devkit-emmc sda1), the host PC reports the operation was successful but when the Jetson boots up it hangs during the boot sequence, and gives an error indicating sda1 was not found.
  • Similar failure occurs if I try flashing using initrd instead (eg using sudo ./tools/kernel_flash/l4t_initrd_flash.sh jetson-xavier-nx-devkit-emmc external)

Any suggestions on how to successfully install Jetpack 5.0.2 to the SSD on this machine ?

Suggest to contact with Seeed/LeeTop as they design the carrier board, not sure any change at the bootloader.


I experienced the same issues with a Jetson AGX with a nvme ssd (Samsung 970 Pro, 512 GB).
Finally made the upgrade with the EMMC default storage.

Can Seeed/LeeTop (?) be notified


I’ve put in a support request to Seeed Studio. Will see if they can help.

But further digging suggests the problem is due to the SATA drive being connected via a USB hub on the board which cboot doesn’t fully enumerate for mass storage devices. Seems to be a common issue - found many threads on this forum relating to cboot and usb drives. Typical example from Boot rootfs from USB drive or SD:

I’ve tried a few things without luck. It’s not clear to me exactly how to split the /boot directory and rootfs partition between emmc and SATA drive.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.