Flash NX Floyd : Error: Return value 6

I have a Floyd board with a Xavier NX production module.

I have already flashed this module with JetPack 4.4.1 with E-con Systems modifications (for camera drivers).
Recently, I wanted to reflash the module with the same JetPack and other modifications. I put the board in RCM and launched this command as usual : sudo ./flash.sh floyd/Xavier-NX/fld-ar1335-4lane mmcblk0p1

But now I receive this error, and the flash is not successful :
[ 9.6406 ] tegradevflash_v2 --pt flash.xml.bin --create
[ 9.6413 ] Bootloader version 01.00.0000
[ 9.7063 ] Erasing spi: 0 … [Done]
[ 12.7602 ] Writing partition secondary_gpt with gpt_secondary_3_0.bin
[ 12.7603 ] […] 100%
[ 12.8013 ] 000000000e111006: t write %d bytes.
[ 14.9466 ]
[ 14.9466 ]
Error: Return value 6
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

The board is always apparantly always in RCM : Bus 001 Device 016: ID 0955:7e19 NVidia Corp.

Does anybody know how to correctly reflash this module?

Thank you


Please contact with E-con for vendor board issue.


Is it a problem of the carrier board (FLOYD Diamond Solutions)? Or the NX module?
We bought them separately

This is a question that is not able to reply. If this is your first time flashing any jetson platform, I would suggest you contact the carrier board vendor for how to flash their board.

We only deal with Devkit carrier board case.

Thank you for your answer,

I’ve already flashed jetsons on Leopard Imaging and Diamond Solutions, but never encountered this problem.
Also, this particular board had already been flashed once with JetPack 4.4.1 + Econ modifications, and it worked fine. The problem was when I tried to reflash it for a second time

Which make me question, what is the correct procedure to reflash a board? For exemple, if I want to pass from JetPack 4.4.1 to JetPack 4.5.1, should I just put the board in RCM and flash ?
Or special care must be taken ?


I would say you can do some cross check if you have multiple NX modules on your side.

Also, it would be better if you have a devkit to validate. If even devkit cannot get flashed by original sdkmanager + latest BSP version, then it has chance to be hardware problem.

And yes, if you want to reflash the board, then you need to put the board into recovery mode.


I did some cross check with the NX module on other board, it worked ! I can successfully finish the flash.

It must be an error in the Floyd board, I will contact our distributor.
Thank you !

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.