Flashing ArchLinux on Jetson TK1


I tried flashing a TK1 using an ArchLinux root file system as directed in the wiki below.


Unfortunately, when I tried to run the ./apply_binaries script, I get the following error message:

Using rootfs directory of: /home/arch/Linux_for_Tegra/rootfs
Extracting the NVIDIA user space components to /home/arch/Linux_for_Tegra/rootfs
tar: m: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

I tried multiple times and ended up getting the same error. I hope someone is able to help

Did you prefix it with “sudo”? Root authority is required for some of that.

I was logged in as root.

Thanks, but I managed to figure it out. The instructions were made under the assumption that one was running Arch on the host computer and I was running Ubuntu.

I just had to skip the following step:

Next, to preserve Arch’s symbolic directory paths, find any lines that look like:

tar xpfm #…
tar jxpfm #…

And replace them so they look like:

tar --keep-directory-symlink -xpmf #…
tar --keep-directory-symlink -jxpmf #…