Flashing DJI Manifold (Customized Jetson TK1)

I tried flashing Manifold (customized version of Jetson TK1 running Ubuntu 14.04.1) with Linux For Tegra R21.5 by following the instructions from Quick Start Guide on this page:
https://developer.nvidia.com/linux-tegra-r215

*** Flashing target device started. ***
./nvflash  --bct PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.cfg --setbct --configfile flash.cfg  --create --bl fastboot.bin --odmdata 0x6009C000 --go
Nvflash 4.13.0000 started
BR_CID: 0x340010017410c1062000000019060380
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
   chip name: unknown
   chip id: 0x40 major: 1 minor: 1
   chip sku: 0x0
   chip uid: 0x000000017410c1062000000019060380
   macrovision: disabled
   hdcp: disabled
   jtag: disabled
   sbk burned: false
   board id: 0
   warranty fuse: 0
   dk burned: false
   boot device: emmc
   operating mode: 3
   device config strap: 0
   device config fuse: 0
   sdram config strap: 0

RCM communication completed
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb
- 57167/57167 bytes sent
tegra124-jetson_tk1-pm375-000-c00-00.dtb sent successfully
odm data: 0x6009c000
downloading bootloader -- load address: 0x83d88000 entry point: 0x83d88000
download command failed NvError 0x120002
command failure/warning: bootloader download failed (bad data)

Failed flashing ardbeg.

My host computer is running Ubuntu 16.04 on a dual boot and was successfully able to detect the Manifold while on Recovery Mode.

Bus 001 Device 006: ID 0955:7740 NVidia Corp.

Were there any successful attempts to flush a customized Jetson TK1 specifically a Manifold? Can you please share any additional/necessary steps?

1 Like

Reply is here (duplicate threads, though slightly different):
https://devtalk.nvidia.com/default/topic/970174/jetson-tk1/flashing-tk1-dji-manifold-weird-menu-blink/post/5236688/#5236688

Hi you all! Does anyone know how to enter in the BIOS of Manifold? I’ve tried Esc, Delete, Supr, F1, F2, F8, F12, etc and got nothing.

Thank you very much!

Embedded systems don’t have a BIOS. Each board has custom support in a combination of bootloader and device tree. Normally a BIOS for a desktop PC would do things like set up clocks and rail voltages…all of that is manual in the embedded world. How you might change something has a general theme, but details differ depending on hardware and what release is used (for release see “head -n 1 /etc/nv_tegra_release”). R21.7 is the most recent L4T release (“L4T” just being ubuntu plus the hardware specific drivers for the TK1).

Thanks for the reply, the problem is that I upgraded the Manifold and it died (it only shows a black screen with nothing), so I’m trying to restore its system image but I can not achieve it.
I have flashed it but it doesn’t boot anyway, Do you know what can I do?

I though that maybe entering in the bootloader I could change the boot options.

You would flash the board using a normal 64-bit Linux PC as host over a micro-B USB cable while the unit is in recovery mode. Typically this would be the driver package for tools, and the sample rootfs for the file system, but modified for your custom board (versus the Jetson dev kit version…known as the board support package or “BSP”). If you flash the wrong BSP it won’t work because the peripherals surrounding the TK1 SoC will differ. You need to get the BSP from the manufacturer of the DJI Manifold.

FYI, the BSP is basically the customization of the bootloader and device tree mentioned in earlier posts about how embedded hardware differs from a PC by not having a BIOS or UEFI.