Flashing error - ERR: unsupported board revision: D01

Hi,

We received a new batch of TX2 modules and I’m trying to flash our hardware.

The first module I though something was broken and going to RMA. Now second module I get the same error message.

Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands

[ 0.0020 ] Generating RCM messages
[ 0.0028 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm mb1_recovery_prod.bin 0 0
[ 0.0034 ] RCM 0 is saved as rcm_0.rcm
[ 0.0037 ] RCM 1 is saved as rcm_1.rcm
[ 0.0037 ] List of rcm files are saved in rcm_list.xml
[ 0.0037 ]
[ 0.0037 ] Signing RCM messages
[ 0.0044 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[ 0.0052 ] Assuming zero filled SBK key
[ 0.0089 ]
[ 0.0089 ] Copying signature to RCM mesages
[ 0.0095 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[ 0.0104 ]
[ 0.0104 ] Boot Rom communication
[ 0.0110 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml
[ 0.0116 ] BR_CID: 0x81801001645118421000000017fd8300
[ 0.0120 ] RCM version 0X180001
[ 0.0306 ] Boot Rom communication completed
[ 1.0371 ]
[ 1.0398 ] tegrarcm_v2 --isapplet
[ 1.0423 ] Applet version 01.00.0000
[ 1.0607 ]
[ 1.0635 ] Retrieving EEPROM data
[ 1.0638 ] tegrarcm_v2 --oem platformdetails eeprom cvm /build-astro-tx2/tmp/deploy/images/astro-tx2/cvm.bin
[ 1.0664 ] Applet version 01.00.0000
[ 1.1006 ] Saved platform info in /build-astro-tx2/tmp/deploy/images/astro-tx2/cvm.bin
[ 1.1781 ]
ERR: unsupported board revision: D01

Could anyone tell me of what the issue is here?

Thanks,
-Damien

I also built an image for the NVidia dev kit carrier and get similar error:
ERR: unsupported board revision: D00

So it’s not only an issue with the custom carrier.

Hi, can you please take a photo of serial number of module so that we can check its status? Thanks.

Could you delete this cvm.bin file and reflash it again? Do you ever use i2c tool to write anything on this module?or it is just totally a fresh one.

Hi,

Here it is:

I went through our stock and we have:

  • 5 x 699-83310-1000-D01
  • 1 x 699-83310-1000-D00

The previous board we used were 699-83310-1000-B02.

We use L4T-tegra186-28.2.0-r0

@WayneWWW I tried this but still get the same error.

They are all fresh modules.

Hi,

I’m getting same issue here. We are also using yocto based image for the device like you and what i did is modified the tegra186-flash-helper.sh script by replacing the part where it checks the revision: B0[1-9]) -> D0[1-9])

Now device is flashed but the hdmi does not work.

Our device is also directly out-of-the-box without prior flashing.

Did check from latest L4T 32.1 bsp package and there is no difference in configuration files available (no D revision), but of course content of the configuration files are different because 32.1 uses newer kernel etc.

@Pasi, thanks a lot for the pointer. It solved it for me.

I first checked if I was able to flash Jetpack 3.2 on dev kit and it went through with HDMI working.

The JetPack flash command is

./tegraflash.py 
--bl nvtboot_recovery_cpu.bin 
--sdram_config P3310_A00_8GB_Samsung_8GB_lpddr4_204Mhz_A02_l4t.cfg 
--odmdata 0x1090000 
--applet mb1_recovery_prod.bin 
--cmd "flash; reboot" 
--cfg flash.xml 
--chip 0x18 
--misc_config tegra186-mb1-bct-misc-si-l4t.cfg 
--pinmux_config tegra186-mb1-bct-pinmux-quill-p3310-1000-c03.cfg 
--pmic_config tegra186-mb1-bct-pmic-quill-p3310-1000-c04.cfg 
--pmc_config tegra186-mb1-bct-pad-quill-p3310-1000-c03.cfg 
--prod_config tegra186-mb1-bct-prod-quill-p3310-1000-c03.cfg 
--scr_config minimal_scr.cfg 
--scr_cold_boot_config mobile_scr.cfg 
--br_cmd_config tegra186-mb1-bct-bootrom-quill-p3310-1000-c03.cfg 
--dev_params emmc.cfg  
--bins "mb2_bootloader nvtboot_recovery.bin; mts_preboot preboot_d15_prod_cr.bin; mts_bootpack mce_mts_d15_prod_cr.bin; bpmp_fw bpmp.bin; bpmp_fw_dtb tegra186-a02-bpmp-quill-p3310-1000-c04-00-te770d-ucm2.dtb; tlk tos.img; eks eks.img; bootloader_dtb tegra186-quill-p3310-1000-c03-00-base.dtb"

After verifications in tegra186-flash-helper.sh the command is identical to B0[1-9] version.

Then I flashed my image on Astro and everything works.

I’ll submit the fix to meta-tegra layer.

Cheers!

Hi Damien,

Sorry I didn’t get what is your fix here. Could you elaborate it? BTW, what is " tegra186-flash-helper.sh" ?

Looks like tegra186-flash-helper.sh is an e-con Systems script.

It’s from meta-tegra layer. We use it to build image + toolchain for jetson and do not use Nvidia provided packages.

https://github.com/madisongh/meta-tegra/blob/master/recipes-bsp/tegra-binaries/files/tegra186-flash-helper.sh

tegra186-flash-helper.sh is a script added to meta-tegra layer for flashing devices:

https://github.com/madisongh/meta-tegra/blob/f74dd569798b0387b78cce854713e5852a0bae1a/recipes-bsp/tegra-binaries/files/tegra186-flash-helper.sh

It checks for the board revision to flash the correct dtb, pinmux, etc files to the device.

The issue was already fixed in newer branch, but not in the older branch we are using.

So it’s not a problem in JetPack.

@pasi.petajajarvi I’ve had the HDMI issue at the beginning of our project. It was due to missing BSP for Astro carrier. So wrong dtb and pinmux files flashed to device.

Thanks for clarification.