Flashing failure

I have an Xavier device and it has kernel issues so i want to reflash it and stast from scratch.
when i flash it i get an error

Error: Return value 3
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

full log is here
i’m flashing from a physical server (not vm) running Ubuntu18.04
MobaXterm_apollo01_20190715_091834.txt (292 KB)

New Text Document.txt (293 KB)

Hi rafiwiener,

Are you flash by manually or using sdkmanager?
Sorry, I can’t open your log, please upload on topic.

FYI, if you hover your mouse over the quote icon in the upper right of your existing post, then the paper clip icon will show up. You can use that to directly attach your flash log.

attached two logs, i tried twice with no success
i tried with sdkmanager and it failed this log is from the manual run.

If the file name suffix is something the forum doesn’t expect, then it might reject the file. Does it have a “.txt” file name suffix? Actually, I do see one made it through, the other is scanning. This is the basic error:

[  12.1798 ] [.                                               ] 002%
[  15.8490 ] 
Error: Return value 3
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

I’m not sure what return value 3 is.

and at what point it fails if you wipe sdkmanager folders and purge it and reinstall it back and try flashing the default flash image with it?

i tried wiping and flashing still fails

I see a lot of this which seems wrong:

[   3.7977 ] Parsing config file :tegra194-mb1-bct-scr-cbb-mini.cfg 
[   3.7979 ] Added Platform Config 1 data with size :- 19640

[   3.8095 ] Parsing config file :tegra19x-mb1-padvoltage-p2888-0000-a00-p2822-0000-a00.cfg 
[   3.8097 ] Added Platform Config 2 data with size :- 24

[   3.8099 ] Parsing config file :tegra194-mb1-bct-pmic-p2888-0001-a04-E-0-p2822-0000.cfg 
[   3.8101 ] Added Platform Config 4 data with size :- 348

You’re also operating from a “/mnt” location which is non-standard. I’m thinking that if instead of mounting something there (I’m assuming you don’t have enough disk space without that), then you could mount instead at “~/nvidia/” instead. Do make sure whatever you are mounting has space and it is formatted as ext4.

it turns out i had a quota limitation on my work dir and i think this caused is (although i worked in folder without this limitation). after using a different server to flash from all passed well