Flashing Jetson TX1 with Orbitty Carrier using the flash.sh script (CUDA won't install)

Hi,

I successfully flashed the Jetson with:

sudo ./flash.sh orbitty mmcblk0p1

However, CUDA wasn’t installed and I’m assuming the reason is the same as in this:
https://devtalk.nvidia.com/default/topic/1039445/jetson-tx2/getting-cuda-installation-error-after-flashing-jetpack-3-3-successfully-/
topic.

I’m assuming I need to plug the Jetson to the same router as my host machine, but I’m not sure what exactly should I pass to the flash.sh script for it to follow point 11. in the installation guide:
https://docs.nvidia.com/jetson/jetpack/index.html#jetpack/4.1.1/install.htm%3FTocPath%3D_____3

When you run the command on your host of “ifconfig” there is a label for each device. Some devices are virtual, e.g., “lo” is loopback. Other devices with a naming convention like “eth0” or “enp4s2” or similar are actual network devices. Most people will have only one actual network device (I have more than one, but that’s unusual). The one which matches what you have is the one to choose. This is the network card which can route to wired network.

FYI, JetPack will pass the right details to flash.sh, but those details only occur for flash and do not involve package install. The Jetson reboots after a flash and then package install occurs over ethernet. You can in fact disable flash and run package install any time you want.

I have to admit I didn’t get it :(

My understanding was that I need to somehow tell the script at which IP can the Jetson be found.

So I tried:

sudo ./flash.sh -N 192.168.1.20:/nfsroot orbitty eth0

And as a result I saw the following message on the host:

...
*** The target t210ref has been flashed successfully. ***
Make target nfsroot(192.168.1.20:/nfsroot) exported on the network and reset the board to boot

However, on the Jetson I saw:

and after a while:

How can make the target exported on the network?
What does it mean?

OK,

I guess my previous attempt was dumb, but what eventually worked was:

https://github.com/NVIDIA-AI-IOT/jetson-trashformers/wiki/Jetson%E2%84%A2-Flashing-and-Setup-Guide-for-a-Connect-Tech-Carrier-Board

Just FYI, flash.sh uses only the USB connection to a Jetson in recovery mode. It’s called the driver package because in recovery mode the Jetson is a custom USB device understood only by a custom driver. JetPack is just a front end, and it uses the driver package for flash. Network addresses are only used when the driver package is completely done and no longer participating as a way to install packages. I haven’t used NFS as a rootfs source, but I think this is all it is…a substitute for the sample “rootfs/” subdirectory by naming an NFS location.

Good to know, thanks :)