Flashing Jetson TX2 for use with Auvidea J120 carrier board

Hi there, I apologize in advance for being a noob, but I recently acquired a Jetson TX2, and without ample knowledge, I’ve been unable to figure out how to flash the TX2 so I can use it on my J120 carrier board. Auvidea provided me pretty straightforward instructions, which I was able to follow without any problem until updating the firmware for use on the J120. So, I successfully installed JetPack 3.1 on my Jetson, but am now stuck on the firmware.

I downloaded version 1.5 of the firmware from here: https://auvidea.com/firmware

After downloading and extracting:

I move the files from the BCT folder of ChangesTX2J140_Kernel_r28.1 to the bootloader for JetPack, Auvidea’s instructions then say execute these commands in terminal:

cd ~/Desktop/ChangesTX2J140_Kernel_r28.1/BCT/

sudo cp -rf tegra186-mb1-bct-pmic-quill-p3310-1000-c0* ~/Desktop/JetPack3.1/64_TX2/Linux_for_Tegra_tx2/bootloader/t186ref/BCT/.

I’m able to run those commands without any issue, however, when I attempt to flash the TX2, I use:

sudo ./flash jetson-tx2 mmcblk0p1

I get the error:

sudo: ./flash: command not found.

I’m assuming there’s some sort of package I need to download to run that command, however, I have no idea what it is. This has been a very aggravating and lengthy process, and I just haven’t been able to figure it out. Any help would be greatly appreciated. Auvidea’s customer support is very slow, and not very helpful. Please let me know if I left out any pertinent information.


It’s “flash.sh” instead of “flash”.

I tried that, but I get the same error :(

It makes me think there is a problem locally as opposed to with the Jetson, or carrier board.

I’m running Ubuntu 16.04 on a Mac mini

The directory you are in at the moment should be “…/some/where/Linux_for_Tegra/” (type “pwd” to see where you are). The flash.sh file is from the driver package, and when using JetPack this will be automatically downloaded. There may be options to delete this after it runs, which could explain the file not being there if you downloaded via JetPack and then later tried to run the command.

Normal unpack of the driver package will correctly set permissions of flash.sh. If something strange occurred and the permissions were incorrect, then you might get the same result as a missing file.

Ok, I’ve found the flash.sh file, which was in the Linux_for_Tegra folder

I looked up the permissions, and this is what I got:

-rwxr-xr-x 1 Mac Mac 51323 Jul 20th

I’m not sure what exactly that means, but the file is there.

Any feedback on how to change the permissions for this file?

Those permissions are correct. The command though should use the name “flash.sh” and not “flash”. Leaving off the “.sh” would cause failure. Example:

sudo ./flash<b>.sh</b> -S 29318MiB jetson-tx2 mmcblk0p1