Flashing Jetson TX2

I am currently using a Cogswell Carrier Board for the Jetson TX2. I have put the board into recovery mode as told by the installation guides and forums online, and when I plug it into my laptop via USB and I use lsusb on the host machine it returns “Bus 003 Devices 005:ID 0955:7c18 NVIDIA Corp. TI86 [TX2 Tegra Parker] recovery mode”. However, the problem I am having is that because I need to use a virtual machine to flash the board, when I type lsusb in the virtual machine terminal, I get “Bus 001 Device 004: ID 0955:7c18 NVidia Corp.” and when I try to flash the board is gives me an error saying that I need to put the board in recovery mode. Can someone help me to fix the virtual machine telling me that the board is not in recovery mode yet but host is? Just to let you know in the virtual machine I have got the same problem in vmware player and VirtualBox, and I am trying to use Ubuntu 18.04 LTS Bionic. Thanks in advance, if any clarification is needed, just let me know I am happy to give more details.

Edit: I have also tried using a Ubuntu host system (22.04 LTS) and then a Windows Host System and no difference

  • I have tried many forums with any help, if someone has an idea feel free to help.

The VM is not supported by SDK manager, you need to have a host PC with Ubuntu 18.04.
Or you may refer to below thread t osee if can help: Flashing Jetson Nano 2GB with VM - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums
Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.