Flashing Jetson Xavier fails

it is not a hard requirement, but if I were you I would test to see if it works

I tried using this method, USB C <–> USB Male + USB Female <–> USB C.

The board got detected successfully but result is same. Flashing stops at 0.8%. Do you feel, is there a problem on the board ? Should I return ?

Kindly suggest a way out .

FYI: I tried with another laptop as well, via a Virtual machine , flashing stopped at 99% and never moved after that.Only then I decided to go for a dedicated laptop with ubuntu. But here probing error happens.

can you try without virtual machine at another computer?
virtual machine flashing is not officially supported;
often works though, but requires treefold time consumption
for virtualbox it takes to enable usb 3.0 controller in vbox settings

Sorry, I have a laptop with windows 7, 32 bit version, I5 processor. Only way, I have to install Virtual machine on that machine. But in one of your post, you have mentioned that 32 bit will not work.So I ran out of options.

Where do you feel the problem lies. I could see the USB Port is working fine. Even the C port gets detected. I am confused.

all the attemots above;
were they approached from virtual machine?
from not a virtual machine?

All the attempts, what ever you suggested, is done through a Non-virtual, dedicated machine with ubuntu 18.04 Bionic.

Along with this I have also tried with a virtual machine.

Results

Dedicated machine with ubuntu 18.04 - Flashing stops at 0.8%
VM Machine (tried on my own) - Flashing stops at 99 %

If I had a liberty to do so I would reinstall uubntu at the Host PC to avoid troubleshooting the environment issues;
In case there is no such liberty, it would require to troubleshoot existing OS restrictions/limitations in order to proceed with the flashing;
Maybe second ubuntu OS can be installed onto a differnt partition?

Unfortunately, I don’t have the liberty to reinstall or to create a partition and install another ubuntu.

Sorry :(

I would be happy to even give you access to my computer, if you wanna check the environmental issues.

FYI: This is a brand new laptop, with zero installations. This laptop was first unpacked and used for Flashing only.

what virtual machine did you use? has it had at least 50gb free disc space ?

I used Oracle Virtual Box 6.1.12. The VM ware Virtual player cannot be as it is not allowed for commercial application.

There was enough space more than 70 GB. The flashing stopped exactly at the below line,

tegrarcm_v2 --isapplet

This error is similar to the error many reported in the below link,

Many suggested to use VM ware player, but even that I cannot use, as it is not allowed for commerical applications

was the usb 3.0 controller enabled in VM settings -> USb ports configuration ?

Dear Andrey,

I have tried with both the options, USB 2.0 and USB 3.0. Please refer the below image,

What ever I opt (2.0 or 3.0), where ever I change the USB port (tried all 3 ports), in the VM machine the flashing stops at 99%

could you do the following:

  1. find a usb-flash[stick/pen drive] that will have ubuntu livecd
  2. find another external usb storage
  3. boot from 1 so that installation of fresh Ubuntu will be made onto the 2;
    So that all system drives will remain intact, but there will still be fresh OS installation of Ubuntu desktop?
    there was somewhere docker installation methid tyhat might work

You mean 2 external usb storage devices. one with ubuntu and other to download and install packages.

Am I right ?

Also, is there a possibility to flash the SD Card and insert the SD card on the AGX Board. I could see this option in Jetson NX. Is it possible in Jetson AGX ?

I used that approach when I had limited Host PC availability; have had multiple usb storages; eventually it worked;
It is one of possible solutions;
I mean one storage with live ubuntu;
The second is to install ubuntu from the first one;
to download packages & create target image generic hard disk can be used, as it will do no impact to the system OS

1 Like

@somasundaram.s
what if you disk shrunk space of your windows laptop e.g making it 100gb less and install ubuntu Os as second to there? so it would be possibble to try from it?

Dear Andrey,

Modifications in the present laptop is impossible, as this belongs to my organisation.

Hello Andrey,

Finally I could successfully flash the hardware with a different machine. But now this error shows up,

Can you please guide .

well done!
did you set username and password?

Hello Andrey,

I have completed the entire process. Only Deep stream is giving problem now. Rest all done :D

Please refer the image,

Why is deep stream not downloading ?