Flashing my tx2-nx

Continuing the discussion from Cannot enter recovery mode after flash failure:
SDKM_logs_JetPack_4.5.1_(rev.1)_Linux_for_Jetson_TX2_NX_2022-06-09_11-43-12.zip (1.1 MB)

I have tried many ways to flash my tx2-nx device with using flash.sh in my terminal as well as using sdk manager but failed both time with various errors on both terminals. I have ubuntu 18.4 with jetpack version 4.5. The error that i got by using script was flash haas completed but with errors, while using sdkmanager i got the logs below.

any suggestions could be most helpful
Thank you

Could you also try to use jetpack4.6.1 ?

I checked your log. Since it just says your module is not in recovery mode, how about you really check whether you module is in recovery mode or not?

It could be

  1. Your board is not really in recovery mode at all.
  2. Your board is in recovery mode, but your usb cable is not fine.
  3. Your board is in recovery mode, but your host cannot detect it (most VM ubuntu case)

I checked the scenarios i can see the usb detected in terminal and have double checked that the device is in recovery mode

have tried using 4.6.1 but encountered with same error!

What is your method to tell whether the board is in recovery mode?

Checking in the lsub that nvidia corp is present or not?

correct me if i am wrong

Checking in the lsub that nvidia corp is present or not?

Not 100% correct.
What number do you see in lsusb?

How was your method to put your board into recovery mode?

This is the answer for your first question:

(base) ultron@ultron:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 8087:0a2b Intel Corp.
Bus 001 Device 003: ID 0b05:1837 ASUSTek Computer, Inc.
Bus 001 Device 002: ID 0bda:57fa Realtek Semiconductor Corp.
Bus 001 Device 011: ID 0955:7c18 NVidia Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

i have connected the 6th port to the ground pin(i.e 2nd pin)

Is this the devkit or some custom carrier board?

Have you checked the uart console? If this is recovery mode, then uart console shall give you no response.

And do you have other usb cable and ubuntu host that can flash devices?

And do you have any other jetson devices to validate the flash functionality on your host? no matter nano, nx or any jetson devices are fine.

it is a custom carrier board
no idea about uart console
yess chcecked with couple of new usb cables
i am having another nano device

So are those nano devices can get flashed by your host machine and usb cable?

The method to dump the console log is over here.

We only have the method for devkit. If you are using some custom board from some vendor, please contact the board vendor to know how to dump.

yes flashed nano with the same device and host

when i connect my device through usb the name of device will be nx2 and complete name is showing

Are you able to use the nx devkt for your tx2-nx and see if you can flash it in such case?

tried flashing 2 days before but have landed up getting a prompt saying flash successful and in bracket with errors

Could you point out which log is that? Your zip file seems not have that log at all.

yes now i am trying to flash the device but i am stuck with this error of cannot enter into recovery mode bad condition

Please just try to use devkit to validate. “Cannot flash” is mostly pure hardware issue for jetson part.

Actually our software is trained with jetpack 4.5.1 so now flashing with 4.6.1 effects?