Flashing new kernel not updating defconfig

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.8.1
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Hi,

I followed the path to recompile kernel as per below link.

In step of doing menuconfig I am enabling the PPS config parameters. I follow the remaining steps and also the corrections for step 12.b

I am able to flash with bootburn but when i check after, the parameters are still unset like below

nvidia@tegra-ubuntu:~$ gunzip < /proc/config.gz | grep CONFIG_PPS
CONFIG_PPS=y

CONFIG_PPS_DEBUG is not set

CONFIG_PPS_CLIENT_KTIMER is not set

CONFIG_PPS_CLIENT_LDISC is not set

CONFIG_PPS_CLIENT_GPIO is not set

Kindly advice how to enable them.

Thanks!!
Jishnu

Dear @jishnuw,
Does this issue still need support?

Hi @SivaRamaKrishnaNV

I hacked it this time by editing all defconfigs. Not an ideal solution. If I missed a step or two pls do share, else we can close this topic until I face something similar again.

Thanks!!
Jishnu

1 Like

Dear @jishnuw,

If possible, could you share those changes for reference. Thanks

Hi @SivaRamaKrishnaNV

When I say I hacked, after doing menuconfig and setting the required config to (*) We follow the steps ahead, But on flashing I was seeing the CONFIG value still as n. SO what I then did was grepped for all occurrences and set it to yes and re tried flashing. Not the best way to do it.

Currently I don’t have the exact changes since we moved ahead from this state.

Thanks!!
Jishnu

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.