Flashing NVIDIA Jetson TK1

Greetings

I’ve been following NVIDIA’s Two Steps to a Demo to install JetPack L4T on a host computer and flash it to my NVIDIA Jetson TK1. I believe this procedure had been successful but now I’m having trouble in running sample codes.

At the end of the instruction guide the user is allowed to run sample compiled code such as CUDA’s Ocean Simulation; I know which directory they’re located at but cannot open or run the simulation. I’ve tried calling them in terminal but nothing happens. Any help or suggestions to solve this problem would be much appreciated.

Thanks

Hi,

Could you share more information about the issue you meet?

In general, you can launch CUDA sample via following command:
(Remember to modify 8.0 to 6.5 for TK1 use case)

$ /usr/local/cuda-8.0/bin/cuda-install-samples-8.0.sh .
$ cd NVIDIA_CUDA-8.0_Samples/5_Simulations/oceanFFT/
$ make
$ ./oceanFFT

Thanks.

The current Ubuntu OS that I’m using is 16.04 and I’ve tried your method:

cd TK1/NVIDIA_CUDA-6.5_Samples/5_Simulations/oceanFFT make
$./oceanFFT

After $make I get an error saying unsupported GNU version! gcc 4.9 and up are not supported. And after calling ./oceanFFT another error states ./oceanFFT: No such file or directory. The latter makes sense as I am already in the oceanFFT directory that contains certain files related to the CUDA Ocean Simulation.

Could it be that I need to install updates or if this isn’t the right OS version?

Hi,

There are two kinds of CUDA toolkit can be installed via JetPack:

1. Host-Ubuntu
This is x86 version CUDA toolkit.
Suppose that you are not using this.

2. Target-Jetson TK1
This is arm-version CUDA toolkit.
OS version is 32-bit Ubuntu14.04.
Please run the CUDA sample right on the TK1.
You can execute the sample directly on the device or access it via ssh.

Thanks.

AastaLL

Are you implying that I would have to install the CUDA toolkit manually rather than having it become installed through flashing the NVIDIA Jetson TK1?

JetPack is a front end to other software…one thing it can do is flash. The other thing is it can download software and install it. One never needs to flash to add CUDA…flashing would in fact erase the system and make you install software from scratch (when you flash it reboots part way through…this is when flash is complete and the software download can begin). All you have to do is uncheck the flash and uncheck any components you don’t want, then check the one you do want on the platform you want (remember, you can add packages to both host PC and Jetson…you may just want it on the Jetson…make sure the PC side is not checked to install to that).

When you do install software it tends to be found in “/usr/local/”.

I have find out that the real reason none of running samples were working (and many were also missing) was that my host PC had a different Ubuntu version from the TK1’s Ubuntu Version. I flashed the download from the host PC and the Nvidia jetson tk1 and now the program samples are now running and are all there

But not all of them run or work, in particular the FFT Ocean Simulation that I want to run from the start. I call it from terminal and it states an error saying:

[CUDA FFT Ocean Simulation]
Error unable to find GLSL vertex and fragment shaders

Any explanations to why this may be or any suggestions to fix this sort of problem??

Issue was caused by non NV graphic card on host PC, see relevant discussion in https://devtalk.nvidia.com/default/topic/1028876/nvidia-drivers-on-ubuntu-14-04/