Flashing of Nvidia jetson orin nx board

nooo its showing nothing

Then how does it work if you re-flash it now?
Check both flashing log and serial console log.

if we reflash it working good and also there is no booting issue there but when i tried to update or upgrading commands or tried to download cuda tool kit then after theses things its getting stucked at booting only

That should not be the case.
What exact commands did you run?

i have used these commands only i mean above mentioned at starting

OK.
So this is a forecr board, definitely not a DevKit…
Please do not run sudo apt upgrade on any custom boards.
They are only meant to be used on DevKits.

@kckumar if you need to upgrade the packages, you need to hold L4T packages at least. Otherwise, the system will upgrade the packages with L4T packages together for DevKit as @DaveYYY said.
To do this, you need to run:

sudo apt-mark hold 'nvidia-l4t-*'

Our reference blog is located in here:

okay but when i downloaded cuda tool kit also its behaving like this only !

After the SDK Components installed, you can hold them. Otherwise, you can not install the CUDA and the other packages
You need to unhold them, install the SDK components and hold them again

when i compiling the python files for tracking putpose its showing
Assertion Error: Torch not compiled with cuda enabled can please solve this?

File another topic for your question.

i filed two topics but no one is responding to that?